summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-04 06:08:32 +1300
committercaltlgin2020-10-04 06:08:32 +1300
commit9481b4e9de4d77a46994a3bbf11c1eb29eec0773 (patch)
tree42506496578864ff950fa5f732c1d51f5740f143
downloadaur-9481b4e9de4d77a46994a3bbf11c1eb29eec0773.tar.gz
Add to AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b62b30a851bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bashmount-git
+ pkgdesc = Tool to mount and unmount removable media from the command-line
+ pkgver = 0.43.r17.g1f75f01
+ pkgrel = 1
+ url = https://github.com/jamielinux/bashmount
+ arch = any
+ license = GPL2
+ makedepends = git
+ optdepends = udisks2: manage removable media without sudo
+ provides = bashmount
+ conflicts = bashmount
+ backup = etc/bashmount.conf
+ source = git+https://github.com/jamielinux/bashmount.git
+ sha256sums = SKIP
+
+pkgname = bashmount-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50830a6a30d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='bashmount'
+pkgname="${_pkgname}-git"
+pkgver=0.43.r17.g1f75f01
+pkgrel=1
+pkgdesc='Tool to mount and unmount removable media from the command-line'
+arch=('any')
+url='https://github.com/jamielinux/bashmount'
+license=('GPL2')
+makedepends=('git')
+optdepends=('udisks2: manage removable media without sudo')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+backup=("etc/${_pkgname}.conf")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+package() {
+ cd "${_pkgname}"
+ install -Dm755 -t "${pkgdir}/usr/bin" "${_pkgname}"
+ install -Dm755 -t "${pkgdir}/etc" "${_pkgname}.conf"
+ install -Dm644 -t "${pkgdir}/usr/share/man/man1" "${_pkgname}.1"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.md'
+}
+
+# vim: ts=2 sw=2 et: