summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin lyons2018-02-18 22:45:47 +0000
committerGavin lyons2018-02-18 22:45:47 +0000
commit3214fe053f974edc8a8dac6f0ebb0a4f6a15dfa8 (patch)
tree45dfc2fc76d6a076f6ea18083107b03b41aae076
downloadaur-3214fe053f974edc8a8dac6f0ebb0a4f6a15dfa8.tar.gz
version 1.1-2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1735bcd21437
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = bashmultitool
+ pkgdesc = A library for bash shell program containing useful functions, written in bash import into scripts
+ pkgver = 1.1
+ pkgrel = 2
+ url = https://github.com/gavinlyonsrepo/bashmultitool
+ arch = any
+ license = MIT
+ source = https://github.com/gavinlyonsrepo/bashmultitool/archive/1.1.tar.gz
+ md5sums = c07b1f8041515c6addb48a8b0176a76b
+
+pkgname = bashmultitool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8456398866f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gavin Lyons <glyons66@hotmail.com>
+# https://github.com/gavinlyonsrepo/bashmultitool
+pkgname=bashmultitool
+pkgver=1.1
+pkgrel=2
+pkgdesc="A library for bash shell program containing useful functions, written in bash import into scripts"
+arch=('any')
+url="https://github.com/gavinlyonsrepo/bashmultitool"
+license=('MIT')
+
+source=("https://github.com/gavinlyonsrepo/bashmultitool/archive/$pkgver.tar.gz")
+
+md5sums=('c07b1f8041515c6addb48a8b0176a76b')
+
+package() {
+
+ cd "$srcdir/${pkgname}-${pkgver}"
+
+ install -D -m644 README.md "$pkgdir/usr/share/doc/${pkgname}/Readme.md"
+ install -D -m644 documentation/Features.md "$pkgdir/usr/share/doc/${pkgname}/Features.md"
+ install -D -m644 documentation/changelog.md "$pkgdir/usr/share/doc/${pkgname}/changelog.md"
+ install -D -m644 documentation/License.md "$pkgdir/usr/share/licenses/${pkgname}/License.md"
+
+
+ install -d "$pkgdir"/usr/lib/bashmultitool
+ install -D -m644 lib/* "$pkgdir"/usr/lib/bashmultitool
+}