summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2023-08-16 18:26:29 -0400
committerStorm Dragon2023-08-16 18:26:29 -0400
commit2cad9fcbb8658e17079b575cc00262a211c9383e (patch)
treef2f9f1bcf120a578b7e35c920005edbfde80bb0c
parent84f789a6fac11e688acaf7a20b435392f0c26620 (diff)
downloadaur-bashtuner.tar.gz
More changes were needed, should work now.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e1a9a53fd6f..9a966663db21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,11 +5,12 @@ pkgbase = bashtuner
url = https://git.stormux.org/storm/bashtuner
arch = any
license = unlicense
+ makedepends = git
depends = dialog
depends = sox
provides = bashtuner
conflicts = bashtuner
- source = https://git.stormux.org/storm/bashtuner/-/archive/2019.04.20/bashtuner-2019.04.20.tar.gz
- sha512sums = 6df491fdfb30552d85a931f2f3ccba2160786ce3bd08a87fa13baed0c0b98ce2efd1dab776b0517ebd1907f7de0a2681ff1f54c63a6ad022a4908fc9d9cc300f
+ source = git+https://git.stormux.org/storm/bashtuner.git
+ sha512sums = SKIP
pkgname = bashtuner
diff --git a/PKGBUILD b/PKGBUILD
index 295efe3d836b..ef3d2416db62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,22 @@ pkgrel=1
pkgdesc="A guitar tuner written in bash with several tunings, and support for some other stringed instruments"
arch=('any')
url="https://git.stormux.org/storm/$pkgname"
-source=("${url}/-/archive/$pkgver/${pkgname}-${pkgver}.tar.gz")
+source=("git+${url}.git")
license=('unlicense')
depends=('dialog' 'sox')
+makedepends=('git')
provides=("$pkgname")
conflicts=("$pkgname")
-sha512sums=('6df491fdfb30552d85a931f2f3ccba2160786ce3bd08a87fa13baed0c0b98ce2efd1dab776b0517ebd1907f7de0a2681ff1f54c63a6ad022a4908fc9d9cc300f')
+sha512sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git checkout v2019.04.20
+}
package()
{
- tar xf ${pkgname}-${pkgver}.tar.gz -C "$srcdir"
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
install -d "$pkgdir/usr/bin/"
install -Dm755 "${pkgname}.sh" "$pkgdir/usr/bin/$pkgname"
}