summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Doege2015-06-09 11:41:01 +0200
committerMartin Doege2015-06-09 11:41:01 +0200
commitdd1276cef23c0654b0796444033eb71a61e85da0 (patch)
tree64c8c1cf067262d65092a337b418d7980aa89c7a
downloadaur-dd1276cef23c0654b0796444033eb71a61e85da0.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
-rwxr-xr-xbasic256.desktop19
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..702648ce89e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = basic256
+ pkgdesc = Educational BASIC programming environment
+ pkgver = 1.1.4.0
+ pkgrel = 1
+ url = http://www.basic256.org/
+ arch = i686 x86_64
+ license = GPL2
+ makedepends = bison
+ makedepends = flex
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = qt5-webkit
+ depends = qt5-serialport
+ depends = sdl_mixer
+ depends = espeak
+ source = http://downloads.sourceforge.net/kidbasic/basic256_1.1.4.0.orig.tar.gz
+ source = basic256.desktop
+ md5sums = f8792253652b44cfad1d5e41bce7e472
+ md5sums = dfb1ee3ac38d86549ed5673b8ee46b49
+
+pkgname = basic256
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c0d00ce0d29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Martin C. Doege <mdoege at compuserve dot com>
+# Contributor: Raphael Scholer <rscholer@gmx.de>
+# Contributor: Eric Waller <ewwaller@gmail.com>
+
+pkgname=basic256
+pkgver=1.1.4.0
+pkgrel=1
+pkgdesc="Educational BASIC programming environment"
+arch=('i686 x86_64')
+url="http://www.basic256.org/"
+license=('GPL2')
+depends=('qt5-base' 'qt5-multimedia' 'qt5-webkit' 'qt5-serialport' 'sdl_mixer' 'espeak')
+makedepends=('bison' 'flex')
+source=(http://downloads.sourceforge.net/kidbasic/${pkgname}_${pkgver}.orig.tar.gz
+ "basic256.desktop")
+md5sums=('f8792253652b44cfad1d5e41bce7e472'
+ 'dfb1ee3ac38d86549ed5673b8ee46b49')
+
+build () {
+ cd "$srcdir/${pkgname}-${pkgver}" || return 1
+ qmake BASIC256.pro || return 1
+ make || return 1
+}
+
+package () {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ install -m 755 -D basic256 "${pkgdir}/usr/bin/basic256"
+ install -m 755 -D Examples/basic256_icon.png "${pkgdir}/usr/share/icons/basic256.png"
+ install -m 755 -D "$srcdir/basic256.desktop" "${pkgdir}/usr/share/applications/basic256.desktop"
+ mkdir -p "${pkgdir}/usr/share/basic256/examples"
+ cp -pr Examples/* "${pkgdir}/usr/share/basic256/examples"
+ mkdir -p "${pkgdir}/usr/share/basic256/help"
+ cp -pr wikihelp/help/* "${pkgdir}/usr/share/basic256/help"
+ cp -pr Translations/* "${pkgdir}/usr/share/basic256/"
+}
diff --git a/basic256.desktop b/basic256.desktop
new file mode 100755
index 000000000000..f6aaa7e6d9b6
--- /dev/null
+++ b/basic256.desktop
@@ -0,0 +1,19 @@
+[Desktop Entry]
+Comment=
+Encoding=UTF-8
+Exec=basic256
+GenericName=BASIC interpreter
+Icon=basic256.png
+MimeType=
+Name=BASIC-256
+Path=
+StartupNotify=false
+Terminal=false
+TerminalOptions=
+Type=Application
+Version=1.0
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-SubstituteUID=false
+X-KDE-Username=
+Categories=Application