summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-08-15 01:08:47 -0400
committerChris Severance2015-08-15 01:08:47 -0400
commit2a28559db1ee618845fea9fd3d4c5f7a217eebb6 (patch)
tree34beffffe150ed5855f89273aa4d9fe04a92fa5e
parentc15a2b05df55ee9a4afe61c4f53b46860e45d612 (diff)
downloadaur-2a28559db1ee618845fea9fd3d4c5f7a217eebb6.tar.gz
Version fix to 15.00
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD48
-rw-r--r--basis-pro5-install.sh2
3 files changed, 28 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f017428bb3b..f73595bd7447 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = basis-pro5
pkgdesc = BASIS BBx Progression Pro/5 Business BASIC eXtended for BBj
- pkgver = 15.01
+ pkgver = 15.00
pkgrel = 1
url = http://www.basis.com/
install = basis-pro5-install.sh
diff --git a/PKGBUILD b/PKGBUILD
index 4a56a3a48261..dd8cf10d2a69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,6 +24,7 @@
# Repeat for 64 bit: Linux Kernel v2.6+ AND glibc v2.3+ [Port 6045] - 64-bit
# Choose a BASIS product: Pro/5 Data Server
# Repeat above for 1245 & 6245
+# Place the 6 files in with PKGBUILD
# If you already have license files, run "makepkg -oc" and place them
# in the appropriate z folders. This allows them to be built into the package
@@ -128,7 +129,7 @@
# blmgr/Register.properties -> zblmgr/
# pro5/BASIS.lic -> zpro5/
-_opt_blgmgr_user='chris' # default: root, the license manager should not be run as root
+_opt_blgmgr_user='nobody' # default: root, the license manager should not be run as root
_opt_pro5_sql='pro5b' # default: pro5b for non-sql, pro5s for sql
_opt_pro5_exe='bbx4' # default: pro5, this link will be created in /usr/bin so
# Pro/5 is in the path. Select a name that minimizes the number of
@@ -145,10 +146,10 @@ _opt_pro5_exe='bbx4' # default: pro5, this link will be created in /usr/bin
# makepkg -sCcfi
# To build 32 bit package on 64 bit system
-# CARCH=i686 makepkg -sCcf
+# makepkg -sCcf CARCH=i686
# To build 32 bit multilib package on 64 bit system
-# CARCH=any makepkg -sCcf
+# makepkg -sCcf CARCH=any
# Once installed with an activated license you can to enable and start the BLM service.
@@ -186,7 +187,7 @@ _opt_pro5_exe='bbx4' # default: pro5, this link will be created in /usr/bin
set -u
pkgname='basis-pro5'
-pkgver='15.01'
+pkgver='15.00'
pkgrel='1'
pkgdesc=('BASIS BBx Progression Pro/5 Business BASIC eXtended for BBj')
url='http://www.basis.com/'
@@ -246,14 +247,14 @@ _servicefile='basis_lmgrd.service'
# Approximate update frequency, yearly
_vercheck() {
- curl -s -l "${url}availability" | grep -FA1 $'6145\n1045' | sed -e 's:<[^>]\+>::g' | grep '^[0-9]\+\.[0-9]\+$' | tr '.' ':' | LC_ALL=C sort -n | tr ':' '.' # 1>&2
+ curl -s -l "${url}availability" | grep -FA1 $'60455\n10455' | sed -e 's:<[^>]\+>::g' | grep '^[0-9]\+\.[0-9]\+$' | tr '.' ':' | LC_ALL=C sort -n | tr ':' '.' # 1>&2
}
prepare() {
set -u
eval 'cd "${star''tdir}"' # keep git-aurcheck from complaining
mkdir -p 'zblmgr' 'zpro5'
- chmod 644 *.Z zblmgr/* zpro5/* 2>/dev/null
+ chmod 644 *.Z zblmgr/* zpro5/* 2>/dev/null || :
cd "${srcdir}"
# The permissions on these files are horrendous
@@ -296,7 +297,7 @@ prepare() {
chmod 755 install # only root can run install (the installer is fixed with an EUID check later)
# these will be marked immutable during install to prevent root from modifying
- chmod 444 pro5/ext/* pro5/std/* pro5/graphics/*
+ chmod 444 pro5/{ext,std,graphics}/*
# Branding the EXE eliminates the need for the license path in an ENV variable
# Branding didn't work with the Basis installer. Only two files contain BLM_LICLOC.
@@ -340,7 +341,6 @@ prepare() {
unset _badfile
set +u
-#false
}
package() {
@@ -399,26 +399,21 @@ EOF
# We had to add ${pkgdir} to get the install to put the file in the right place
# now we remove the ${pkgdir} slop from the generated file
- local _lmgrfile='blmgr/BasisRunLM'
- sed -i -e "s:${pkgdir}/:/:g" "${_lmgrfile}"
-
- # The systemd service doesn't work right unless you have hash bang on the front
- mv "${_lmgrfile}" "${_lmgrfile}.Arch"
- echo '#!/bin/sh' > "${_lmgrfile}"
- cat "${_lmgrfile}.Arch" >> "${_lmgrfile}"
- chmod 755 "${_lmgrfile}"
- rm -f "${_lmgrfile}.Arch"
-
- # Place the log where logs belong
local _logfolder='/var/log/basis'
- sed -i -e "s:${_basedir}/blmgr/log:${_logfolder}:g" "${_lmgrfile}"
- unset _lmgrfile
+ sed -i -e "s:${pkgdir}/:/:g" \
+ -e "# The systemd service doesn't work right unless you have hash bang on the front" \
+ -e '1i #!/usr/bin/sh' \
+ -e '# Place the log where logs belong. A logrotate is included.' \
+ -e "s:${_basedir}/blmgr/log:${_logfolder}:g" \
+ 'blmgr/BasisRunLM'
+
# the log must be world writable so we can run the manager under a non root user's account
install -d "${pkgdir}${_logfolder}"
chmod 777 "${pkgdir}${_logfolder}"
# should we chown this on install?
# disable BLM CREATE ADD START STOP. We do all this.
+ # CREATE won't work because they can't fix the hash bang problem above.
_outfile='scripts/BasisLicManager'
if ! grep -ql 'Arch Linux' "${_outfile}"; then
touch -r "${_outfile}" "${_outfile}.Arch"
@@ -493,9 +488,14 @@ EOF
# systemd support
install -Dpm644 <(cat << EOF
[Unit]
-Description=Basis License Manager
+# Automatically generated by ${pkgname}-${pkgver} PKGBUILD from Arch Linux AUR
+# http://aur.archlinux.org/
+
+Description=Basis License Manager for Pro/5 (BLM)
After=network.target
+# Changing the user name here may require the following:
+# rm -rf /var/tmp/{.flexlm,lockbasis}
[Service]
User=${_opt_blgmgr_user}
Type=forking
@@ -528,7 +528,7 @@ EOF
unset _licfile
fi
- # Fix script error that makes the user wonder why the installer doesn't reread the phone
+ # Fix script error in 14.0,15.00 that makes the user wonder why the installer doesn't reread the phone
touch -r 'scripts/BasisReg' 'scripts/BasisReg.Arch'
sed -i -e 's:"Delivery"[)] :"Phone")blr_phone="${blr_propval}" ;;\n"Delivery") :g' 'scripts/BasisReg'
touch -r 'scripts/BasisReg.Arch' 'scripts/BasisReg'
@@ -624,6 +624,8 @@ post_install() {
pre_upgrade() {
systemctl stop "${_servicefile}"
+ rm -rf '/var/tmp/.flexlm'
+ rm -f '/var/tmp/lockbasis' # otherwise a user change cannot work
if ! chattr -i "${_basedir}/pro5"/{ext,std,graphics}/*; then
# We must do this because of bug https://bugs.archlinux.org/task/45988
case "${_basedir}" in
diff --git a/basis-pro5-install.sh b/basis-pro5-install.sh
index 82ff806c6dd9..caae6b0f8358 100644
--- a/basis-pro5-install.sh
+++ b/basis-pro5-install.sh
@@ -19,6 +19,8 @@ post_install() {
pre_upgrade() {
systemctl stop "basis_lmgrd.service"
+ rm -rf '/var/tmp/.flexlm'
+ rm -f '/var/tmp/lockbasis' # otherwise a user change cannot work
if ! chattr -i "/usr/local/basis/pro5"/{ext,std,graphics}/*; then
# We must do this because of bug https://bugs.archlinux.org/task/45988
case "/usr/local/basis" in