summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Caldas2023-08-30 00:45:03 +0100
committerRenato Caldas2023-08-30 00:45:03 +0100
commit7b1d15c064973c1511cb58b2e5506f2da05b0df3 (patch)
tree4807b5e066518252908921b0ed4de280e754a079
parent6ea322675e17507e84848cf4e9277060d2a7ce51 (diff)
downloadaur-7b1d15c064973c1511cb58b2e5506f2da05b0df3.tar.gz
Fix pkgver function (remove stray quotes)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cf91ee99cf4..f2bfbf05d701 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = basix-git
pkgdesc = FEniCS finite element basis evaluation library
pkgver = 0.7.0.dev0_r934.571d504
- pkgrel = 3
+ pkgrel = 1
url = https://fenicsproject.org
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 3324143d287f..fd34aef6107a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
pkgname=('basix-git' 'python-fenics-basix-git')
pkgdesc='FEniCS finite element basis evaluation library'
-pkgver="0.7.0.dev0"_r934.571d504
-pkgrel=3
+pkgver="0.7.0.dev0_r934.571d504"
+pkgrel=1
arch=('x86_64')
url='https://fenicsproject.org'
license=('MIT')
@@ -16,7 +16,7 @@ sha512sums=('SKIP')
pkgver() {
cd "$srcdir/basix"
# The main repo unfortunately has no meaningful tags..
- printf "%s_r%s.%s" "$(sed -n -e 's/^version *= *\(.*\)/\1/p' pyproject.toml)" \
+ printf "%s_r%s.%s" "$(sed -n -e 's/^version *= \"*\(.*\)\"/\1/p' pyproject.toml)" \
"$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}