summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-05-06 10:52:38 -0500
committerCarlos Aznarán2024-05-06 10:52:38 -0500
commitfe6e5a17b2cf6c228261c974836be41ef0cdc26d (patch)
treeaf7c9975bc580a2d3b46a063ff41dd6c5c45b80f
parent224855bf22301c829f5fd0a852baeef61a3e2db9 (diff)
downloadaur-fe6e5a17b2cf6c228261c974836be41ef0cdc26d.tar.gz
Update license array
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cf91ee99cf4..17d33c23d303 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = basix-git
- pkgdesc = FEniCS finite element basis evaluation library
- pkgver = 0.7.0.dev0_r934.571d504
- pkgrel = 3
- url = https://fenicsproject.org
+ pkgdesc = FEniCSx finite element basis evaluation library
+ pkgver = 0.9.0.dev0_r1041.8818981
+ pkgrel = 1
+ url = https://github.com/FEniCS/basix
arch = x86_64
license = MIT
- makedepends = git
makedepends = cmake
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
makedepends = python-setuptools
- makedepends = pybind11
+ makedepends = nanobind
makedepends = python-scikit-build-core
makedepends = chrpath
+ makedepends = git
conflicts = basix
conflicts = fenics-basix-git
conflicts = python-fenics-basix
diff --git a/PKGBUILD b/PKGBUILD
index c87d89e2f16e..aa5b972e8006 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Renato Caldas <renato@calgera.com>
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
-pkgname=('basix-git' 'python-fenics-basix-git')
-pkgdesc='FEniCS finite element basis evaluation library'
-pkgver="0.7.0.dev0_r934.571d504"
-pkgrel=3
-arch=('x86_64')
-url='https://fenicsproject.org'
-license=('MIT')
-makedepends=('git' 'cmake' 'python-build' 'python-installer' 'python-wheel'
- 'python-setuptools' 'pybind11' 'python-scikit-build-core' 'chrpath')
-conflicts=('basix' 'fenics-basix-git' 'python-fenics-basix' 'python-basix-git')
+pkgname=(basix-git python-fenics-basix-git)
+pkgdesc="FEniCSx finite element basis evaluation library"
+pkgver="0.9.0.dev0_r1041.8818981"
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/FEniCS/basix"
+license=(MIT)
+makedepends=(cmake python-build python-installer python-wheel
+ python-setuptools nanobind python-scikit-build-core chrpath git)
+conflicts=(basix fenics-basix-git python-fenics-basix python-basix-git)
source=('git+https://github.com/FEniCS/basix')
sha512sums=('SKIP')
-pkgver() {
+pkgver() {
cd "$srcdir/basix"
# The main repo unfortunately has no meaningful tags..
printf "%s_r%s.%s" "$(sed -n -e 's/^version *= \"*\(.*\)\"/\1/p' pyproject.toml)" \
@@ -45,7 +45,7 @@ build() {
}
package_basix-git() {
- depends=('blas' 'lapack')
+ depends=(blas lapack)
cd "$srcdir/basix"
DESTDIR="$pkgdir" cmake --install build
@@ -53,7 +53,7 @@ package_basix-git() {
}
package_python-fenics-basix-git() {
- depends=('basix-git' 'python-fenics-ufl-git' 'python-numpy')
+ depends=(basix-git python-fenics-ufl-git python-numpy)
optdepends=('python-numba: for Numba helper function support')
cd "$srcdir/basix/python"
@@ -63,4 +63,4 @@ package_python-fenics-basix-git() {
# Remove insecure runpath
find "$pkgdir" -iname "_basixcpp*so" | xargs chrpath --delete
-}
+} \ No newline at end of file