summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2021-06-28 23:59:24 +1000
committerMatthew Gamble2021-06-28 23:59:24 +1000
commit31352b72f29b2be25f32ff30cab486449f5b7580 (patch)
tree113c71ede473c0be1db7199dddfaca85e7cfbf43
downloadaur-bask.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
-rwxr-xr-xbask14
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34c709de6c03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bask
+ pkgdesc = Bask in the convenience of a task runner for bash
+ pkgver = 0.10.1
+ pkgrel = 1
+ url = https://github.com/jez/bask
+ arch = any
+ license = LGPL3
+ depends = bash
+ depends = coreutils
+ source = https://github.com/jez/bask/archive/refs/tags/0.10.1.tar.gz
+ source = bask
+ sha512sums = d7146cf7419837d5c929c662fc1c2872865774b78efef065f2483b604490ddfbd4a8b8a1d8986683959b9201cf29d87c0296f2a5b6cbff2a4f05d44646f82fd3
+ sha512sums = f76a150a03132727ae553757e1243a37efb89d1bdb0d3f9a9a664500b4afd7c9222fa9e9ac30fc20a502df20b730adf4879b8a1109d6ad04429cd207e41bf698
+
+pkgname = bask
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e38eb34d4ee1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.pkg.tar.*
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0642ceb8c10f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
+pkgname=bask
+pkgver=0.10.1
+pkgrel=1
+pkgdesc="Bask in the convenience of a task runner for bash "
+url="https://github.com/jez/bask"
+license=("LGPL3")
+arch=("any")
+depends=("bash" "coreutils")
+source=(
+ "https://github.com/jez/bask/archive/refs/tags/${pkgver}.tar.gz"
+ "bask"
+)
+sha512sums=(
+ "d7146cf7419837d5c929c662fc1c2872865774b78efef065f2483b604490ddfbd4a8b8a1d8986683959b9201cf29d87c0296f2a5b6cbff2a4f05d44646f82fd3"
+ "f76a150a03132727ae553757e1243a37efb89d1bdb0d3f9a9a664500b4afd7c9222fa9e9ac30fc20a502df20b730adf4879b8a1109d6ad04429cd207e41bf698"
+)
+
+package() {
+ cd "bask-${pkgver}"
+
+ install -Dm755 "${srcdir}/bask" "${pkgdir}/usr/bin/bask"
+
+ install -Dm644 src/bask.sh "${pkgdir}/usr/lib/bask/bask.sh"
+ install -Dm644 src/cli.sh "${pkgdir}/usr/lib/bask/cli.sh"
+
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/bask/LICENSE.md"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/bask/README.md"
+
+ install -Dm644 completion/bask.bash "${pkgdir}/usr/share/bash-completion/completions/bask"
+}
diff --git a/bask b/bask
new file mode 100755
index 000000000000..34b40bc9ccb7
--- /dev/null
+++ b/bask
@@ -0,0 +1,14 @@
+#!/bin/bash
+
+rootdir="$(dirname "$(readlink -f "$0")")/../.."
+
+if [[ "${FUNCNAME[0]}" == source ]]; then
+ echo "Can't source the 'bask' executable. Instead, source '/usr/lib/bask/bask.sh' directly."
+ exit 1
+fi
+
+# Include core files
+source "${rootdir}/usr/lib/bask/bask.sh"
+
+# Include CLI specific files
+source "${rootdir}/usr/lib/bask/cli.sh"