summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Revelant2023-04-14 18:44:20 +0200
committerNicola Revelant2023-04-14 18:44:20 +0200
commit2b0c0eed550280b680c6f74819160063b4d4a0f2 (patch)
tree43c032f4aa48992b12e8ad105f96bfd694b2abc1
parente52078ba476672297a2499d32c46b7efc0753745 (diff)
downloadaur-2b0c0eed550280b680c6f74819160063b4d4a0f2.tar.gz
Fix checksum
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 198638e39984..35ee55cb937a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = basket
pkgdesc = All-purpose notes taker
pkgver = 2.49b
- pkgrel = 7
+ pkgrel = 8
url = https://basket-notepads.github.io/
arch = x86_64
license = GPL
@@ -15,6 +15,6 @@ pkgbase = basket
source = https://launchpad.net/basket/kde5/2.49b/+download/basket-2.49-beta.tar.bz2
source = basket-libgit2-0.99.patch::https://invent.kde.org/utilities/basket/-/commit/090ac469.patch
sha256sums = e760fc68deb1f56ef02cd4a1773c6cd348b79b88ef5ff5dfb05e66947244f186
- sha256sums = d68cffcb4ab5227524763dd74f707ff8fae2e79121cf6f92c915cc8d8de9724d
+ sha256sums = 28437b7833806ecbef9ae62429d96ee20216c37eaba352a40e6b98949c6abcf0
pkgname = basket
diff --git a/PKGBUILD b/PKGBUILD
index 4187c79c49eb..db832b8d39f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=basket
_pkgver=2.49
pkgver=${_pkgver}b
-pkgrel=7
+pkgrel=8
pkgdesc="All-purpose notes taker"
arch=('x86_64')
url="https://basket-notepads.github.io/"
@@ -16,18 +16,17 @@ license=('GPL')
source=(https://launchpad.net/basket/kde5/$pkgver/+download/basket-$_pkgver-beta.tar.bz2
basket-libgit2-0.99.patch::"https://invent.kde.org/utilities/basket/-/commit/090ac469.patch")
sha256sums=('e760fc68deb1f56ef02cd4a1773c6cd348b79b88ef5ff5dfb05e66947244f186'
- 'd68cffcb4ab5227524763dd74f707ff8fae2e79121cf6f92c915cc8d8de9724d')
+ '28437b7833806ecbef9ae62429d96ee20216c37eaba352a40e6b98949c6abcf0')
prepare() {
- patch -d $pkgname-$_pkgver-beta -p1 < basket-libgit2-0.99.patch # Fix build with libgit 0.99
+ patch -d $pkgname-$_pkgver-beta -p1 < basket-libgit2-0.99.patch # Fix build with libgit 0.99
}
build() {
- cmake -B build -S $pkgname-$_pkgver-beta \
- -DBUILD_TESTING=OFF
- cmake --build build
+ cmake -B build -S $pkgname-$_pkgver-beta -DBUILD_TESTING=OFF
+ cmake --build build -- -j8
}
package() {
- DESTDIR="$pkgdir" cmake --install build
+ DESTDIR="$pkgdir" cmake --install build
}