summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2021-02-19 13:52:05 +0100
committerMartin T. H. Sandsmark2021-02-19 13:52:37 +0100
commitbdaaff10b8fc9a3fc15949c942f82cb3a188c0fa (patch)
treec31175ccdffebb8530be8e338a955bc847c88f9a
downloadaur-basket-git.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4359c9e143f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = basket-git
+ pkgdesc = All-purpose notes taker for KDE.
+ pkgver = 2.49.90.r1501.79a7ef1
+ pkgrel = 1
+ url = https://invent.kde.org/utilities/basket
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = git
+ depends = kcmutils
+ depends = kfilemetadata
+ depends = kparts
+ depends = phonon-qt5
+ depends = libgit2
+ provides = basket
+ conflicts = basket
+ source = git+https://invent.kde.org/utilities/basket.git
+ sha1sums = SKIP
+
+pkgname = basket-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a6259a9bcd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+pkgname=basket-git
+pkgver=2.49.90.r1501.79a7ef1
+pkgrel=1
+pkgdesc="All-purpose notes taker for KDE."
+arch=('i686' 'x86_64')
+url="https://invent.kde.org/utilities/basket"
+license=('GPL')
+depends=(kcmutils kfilemetadata kparts phonon-qt5 libgit2)
+makedepends=('extra-cmake-modules' 'kdoctools' 'git')
+provides=('basket')
+conflicts=('basket')
+source=('git+https://invent.kde.org/utilities/basket.git')
+sha1sums=('SKIP')
+#options=(debug !strip)
+
+pkgver() {
+ cd basket
+ _ver="$(cat CMakeLists.txt | grep "Basket VERSION" | cut -d ' ' -f 3 | tr '\n' '.' | cut -d ")" -f1)"
+ echo "$(echo ${_ver}).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare(){
+ mkdir -p build
+}
+
+#To get debug info, change -DCMAKE_BUILD_TYPE=Release to either "Debug" or "RelWithDebInfo"
+
+build() {
+ cd build
+ cmake ../basket \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}
+