summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadeox2021-06-16 16:21:50 +0200
committerRadeox2021-06-16 16:23:02 +0200
commit6c874321e4784c758c6bd747dcdb4de4bde38e90 (patch)
treea0867bd3a6f315b309bedfa2186b5b8d4fb7ab8b
downloadaur-6c874321e4784c758c6bd747dcdb4de4bde38e90.tar.gz
Version 0.6
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4b4628c8501
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bat-asus-battery-bin
+ pkgdesc = Replicate the functionality of the ASUS Battery Health Charging on Windows which aims prolong the battery's life-span
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://github.com/leveson/bat
+ arch = any
+ license = MIT
+ makedepends = go
+ provides = bat
+ source = https://github.com/leveson/bat/releases/download/0.6/bat
+ sha256sums = 1756a983776cf4f6bd92f7a6a813890f8348006411affa54437e4fe976683570
+
+pkgname = bat-asus-battery-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74891c9728f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Dawid Weglarz <dawid.weglarz95@gmail.com>
+
+pkgname=bat-asus-battery-bin
+pkgver=0.6
+pkgrel=1
+pkgdesc="Replicate the functionality of the ASUS Battery Health Charging on Windows which aims prolong the battery's life-span"
+arch=(any)
+url="https://github.com/leveson/bat"
+license=('MIT')
+makedepends=('go')
+provides=('bat')
+source=("https://github.com/leveson/bat/releases/download/${pkgver}/bat")
+sha256sums=('1756a983776cf4f6bd92f7a6a813890f8348006411affa54437e4fe976683570')
+
+package() {
+ install -Dvm755 "${srcdir}/bat" -t "${pkgdir}/usr/bin"
+}