summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Kobel2018-06-04 17:05:05 +0200
committerVincent Kobel2018-06-04 17:05:05 +0200
commitfc69e1b834cba923ce78c5082048a583c97ac647 (patch)
tree4e583436882f3e3a8bbf524750cb19d3b675efbe
downloadaur-fc69e1b834cba923ce78c5082048a583c97ac647.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ed25cc2f998
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bat-cat-git
+ pkgdesc = A cat(1) clone with wings.
+ pkgver = r205.c91511c
+ pkgrel = 1
+ url = https://github.com/sharkdp/bat
+ arch = x86_64
+ license = Apache-2.0
+ makedepends = git
+ makedepends = rust
+ provides = bat
+ source = git+https://github.com/sharkdp/bat
+ sha256sums = SKIP
+
+pkgname = bat-cat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8741525a4290
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Vincent Kobel (v@kobl.one)
+
+_pkgname='bat'
+pkgname="bat-cat-git"
+pkgver=r205.c91511c
+pkgrel=1
+pkgdesc="A cat(1) clone with wings."
+arch=('x86_64')
+url='https://github.com/sharkdp/bat'
+license=('Apache-2.0')
+sha256sums=('SKIP')
+source=("git+https://github.com/sharkdp/${_pkgname}")
+provides=('bat')
+makedepends=('git' 'rust')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cargo build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -D ./target/debug/${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+}
+