summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Jaap Korpershoek2020-07-13 10:35:14 +0200
committerJan-Jaap Korpershoek2020-07-13 10:35:14 +0200
commit5b6055a70e73f8e84ec77ae8f7da369789ffe519 (patch)
treea5da07e821f2b3e8120a92f370c07a1e96cc2c9c
downloadaur-5b6055a70e73f8e84ec77ae8f7da369789ffe519.tar.gz
Rename from batch
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71d32ba5e869
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = batch-git
+ pkgdesc = A command-line program for batch processing of files using your favorite text editor
+ pkgver = r23.e6410c3
+ pkgrel = 1
+ url = https://github.com/alexherbo2/batch
+ arch = any
+ license = Unlicense
+ makedepends = shards
+ makedepends = git
+ replaces = batch
+ source = git+https://github.com/alexherbo2/batch.git
+ sha256sums = SKIP
+
+pkgname = batch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff365cfa4c5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jan-Jaap Korpershoek <jjkorpershoek96 at gmail dot com>
+pkgname=batch-git
+pkgver=r23.e6410c3
+pkgrel=1
+pkgdesc="A command-line program for batch processing of files using your favorite text editor"
+arch=('any')
+url="https://github.com/alexherbo2/batch"
+license=('Unlicense')
+makedepends=(
+ 'shards'
+ 'git'
+)
+source=('git+https://github.com/alexherbo2/batch.git')
+sha256sums=('SKIP')
+replaces=('batch')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ make build
+}
+
+package() {
+ cd "$pkgname"
+ bindir="$pkgdir/usr/bin"
+ sharedir="$pkgdir/usr/share/$pkgname"
+ mkdir -p "$sharedir" "$bindir"
+ install -Dm755 "${PWD}/bin/batch" "$bindir/batch_process"
+ install -Dm755 "${PWD}/scripts/rename" "${PWD}/scripts/convert" "${PWD}/scripts/relink" "$sharedir"
+}