summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Venries2017-03-18 02:48:03 +0100
committerThomas Venries2017-03-18 02:48:03 +0100
commit8e13bdd8b4ec8018096bed93cb674e0103196aa3 (patch)
tree505e619f139b861c84ea48e412bf8c37c2219fbe
parentb026624bd3c8fc9dfb7f3756292f7721a59e955b (diff)
downloadaur-8e13bdd8b4ec8018096bed93cb674e0103196aa3.tar.gz
Added release v1.0
Enhancement: - Multi-x graphical sessions support (using xpub) - batify as only one udevrule file
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9b8b17a37f5..557aae33dc3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = batify
- pkgdesc = Bash script to trigger plug and battery level notifications using udev and libnotify (multi-xusers).
- pkgver = 0.9
+ pkgdesc = Udevrule to display plug and battery level notifications (multi-x sessions).
+ pkgver = 1.0
pkgrel = 1
url = https://github.com/Ventto/batify.git
arch = any
@@ -11,8 +11,8 @@ pkgbase = batify
optdepends = notification-daemon
provides = batify
conflicts = batify
- source = https://github.com/Ventto/batify/archive/v0.9.tar.gz
- sha256sums = 6a33475e275c895173b234bb0f6e5b9d7e454477d4c7cdb0f0a31621bf6bfdc5
+ source = https://github.com/Ventto/batify/archive/v1.0.tar.gz
+ sha256sums = SKIP
pkgname = batify
diff --git a/PKGBUILD b/PKGBUILD
index a3f1b069d117..72c7f749a97d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Thomas "Ventto" Venriès <thomas.venries@gmail.com>
pkgname=batify
-pkgver=0.9
+pkgver=1.0
pkgrel=1
-pkgdesc='Bash script to trigger plug and battery level notifications using udev and libnotify (multi-xusers).'
+pkgdesc='Udevrule to display plug and battery level notifications (multi-x sessions).'
arch=('any')
url="https://github.com/Ventto/${pkgname}.git"
license=('MIT')
@@ -13,14 +13,9 @@ conflicts=("${pkgname}")
makedepends=('git' 'libnotify')
optdepends=('notification-daemon')
source=("https://github.com/Ventto/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('6a33475e275c895173b234bb0f6e5b9d7e454477d4c7cdb0f0a31621bf6bfdc5')
-
-build() {
- cd ${pkgname}-${pkgver}
- make
-}
+sha256sums=('SKIP')
package() {
cd ${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
+ install -Dm644 99-${pkgname}.rules ${pkgdir}/etc/udev/rules.d/99-${pkgname}.rules
}