summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Venries2016-12-06 19:48:29 +0100
committerThomas Venries2016-12-06 19:48:29 +0100
commitb58796e0b22b85e54d0481fc0cbbf54428da8356 (patch)
treee035cfad7e062278ecf35f1e320c3306ca29f904
parent994f0a45ad68c9672b63d924d1b43f484b3cb8d2 (diff)
downloadaur-b58796e0b22b85e54d0481fc0cbbf54428da8356.tar.gz
Fix dependencies and installation
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f0df2d2bf0e..75bf6db610e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,10 @@ pkgbase = batify
url = https://github.com/Ventto/batify.git
arch = any
license = MIT
+ makedepends = git
+ makedepends = libnotify
depends = bash
+ optdepends = notification-daemon
provides = batify
conflicts = batify
source = https://github.com/Ventto/batify/archive/master.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 1a05c8578bb1..8a989327d252 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,8 @@ license=('MIT')
depends=('bash')
provides=("${pkgname}")
conflicts=("${pkgname}")
-makedepends=('')
+makedepends=('git' 'libnotify')
+optdepends=('notification-daemon')
source=("https://github.com/Ventto/${pkgname}/archive/master.tar.gz")
sha256sums=('SKIP')
@@ -21,5 +22,5 @@ build() {
package() {
cd ${pkgname}-master
- make DESTDIR="${pkgdir}/" install
+ make DESTDIR="${pkgdir}" install
}