summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Roest2019-05-03 12:19:42 +0200
committerVictor Roest2019-05-03 12:19:42 +0200
commitf7f006eed2361a00b8c7b9cf2ff9cce854f5e344 (patch)
tree8fbd9b0931ba4b07f3a58f9d0d1c5d1d494984e9
downloadaur-f7f006eed2361a00b8c7b9cf2ff9cce854f5e344.tar.gz
first
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f209f5d24e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = batify-git
+ pkgdesc = One udevrules file triggering plug and battery level notifications (multi-X sessions support).
+ pkgver = 1.0.r15.g691dc5b
+ pkgrel = 1
+ url = https://github.com/Ventto/batify.git
+ arch = any
+ license = MIT
+ depends = libnotify
+ depends = xpub
+ optdepends = notification-daemon
+ provides = batify
+ conflicts = batify
+ source = git+https://github.com/Ventto/batify.git
+ sha256sums = SKIP
+
+pkgname = batify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43f9ca7ab2a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Victor <victor@xirion.net>
+pkgname=batify-git
+_pkgname=batify
+_xpub=xpub
+pkgver=1.0.r15.g691dc5b
+pkgrel=1
+pkgdesc='One udevrules file triggering plug and battery level notifications (multi-X sessions support).'
+arch=('any')
+url="https://github.com/Ventto/${_pkgname}.git"
+license=('MIT')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+depends=('libnotify' 'xpub')
+optdepends=('notification-daemon')
+source=("git+https://github.com/Ventto/${_pkgname}.git")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 99-${_pkgname}.rules ${pkgdir}/etc/udev/rules.d/99-${_pkgname}.rules
+}