summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Krivosheev2020-05-24 17:28:44 +0300
committerIvan Krivosheev2020-05-24 17:28:44 +0300
commit4b8859993b055eb2c7e8cbabfab07f85be09724f (patch)
tree785d973792b5404cb4ac7935541a18e8677d7808
downloadaur-4b8859993b055eb2c7e8cbabfab07f85be09724f.tar.gz
Init commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de12a3d3d31d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = batify2
+ pkgdesc = Lightweight battery notification
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/ikrivosheev/batify2
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ depends = libnotify
+ source = batify2-0.0.1.tar.gz::https://github.com/ikrivosheev/batify2/archive/v0.0.1.tar.gz
+ md5sums = 71445cdc93601e575edd872abf9f4e94
+
+pkgname = batify2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3df702640a87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ivan Krivosheev <py.krivosheev@gmail.com>
+
+pkgname=batify2
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Lightweight battery notification"
+arch=(x86_64)
+url="https://github.com/ikrivosheev/batify2"
+license=(MIT)
+depends=(libnotify)
+makedepends=(cmake)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+md5sums=('71445cdc93601e575edd872abf9f4e94')
+
+build() {
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+
+ source_dir="${pkgname}-${pkgver}"
+ build_dir="${source_dir}/build"
+ cmake -B "${build_dir}" -S "${source_dir}" \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr/local/' \
+ -Wno-dev
+ cmake --build "${build_dir}"
+}
+
+package() {
+ cmake --build "${pkgname}-${pkgver}/build" --target install
+ install -D -m644 "${pkgname}-${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}