summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpierre2020-10-16 18:42:34 +0200
committerpierre2020-10-16 18:42:34 +0200
commitfc07b6fc3461e8f26c34d2e2ca654a2ab899be5b (patch)
treeb79c6d8218c4bae8ffadd6c05b1303db00b22f47
downloadaur-fc07b6fc3461e8f26c34d2e2ca654a2ab899be5b.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD17
3 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca2d0c69b4e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bato-bin
+ pkgdesc = Small program to send battery notifications
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/doums/bato
+ arch = x86_64
+ license = MPL2
+ depends = libnotify
+ source = bato-bin-0.1.1::https://github.com/doums/bato/releases/download/v0.1.1/bato
+ md5sums = 9a776b90bbb47228c71bb0aacc31d936
+
+pkgname = bato-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0f7bfb2639dd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+bato*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..094034bee74c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Pierre Dommerc <dommerc.pierre@gmail.com>
+
+pkgname=bato-bin
+_pkgname=bato
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Small program to send battery notifications"
+arch=('x86_64')
+url="https://github.com/doums/bato"
+license=('MPL2')
+source=("$pkgname-$pkgver::https://github.com/doums/bato/releases/download/v${pkgver}/${_pkgname}")
+depends=('libnotify')
+md5sums=('9a776b90bbb47228c71bb0aacc31d936')
+
+package() {
+ install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
+}