summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh VanderLinden2017-12-22 19:21:37 -0500
committerJosh VanderLinden2017-12-22 19:21:37 -0500
commit3024e14fde683c6b651bb57733596baebf505a83 (patch)
tree07eec0a22b312f2d0b56e71d4a8f8929cdbd65af
downloadaur-3024e14fde683c6b651bb57733596baebf505a83.tar.gz
Initial pkg
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD24
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfef5c75a5d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = baton-bin
+ pkgdesc = CLI / TUI to remotely manage Spotify playback
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/joshuathompson/baton
+ arch = x86_64
+ license = MIT
+ provides = baton
+ options = !strip
+ source = baton-bin-0.1.2::https://github.com/joshuathompson/baton/releases/download/0.1.2/baton_linux_amd64
+ source = LICENSE::https://raw.githubusercontent.com/joshuathompson/baton/master/LICENSE
+ sha256sums = f508f036eeea1f1eb8a2bc8df5f12b47daefa3094a8d14e1197fd00a28beb46a
+ sha256sums = 3eec9c2f5c8f98f1875dbc57b9a2985313c869456466e09152259a7090f61d20
+
+pkgname = baton-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..315062ad3907
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+LICENSE
+baton*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b60f16bb7695
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Josh VanderLinden <arch@cloudlery.com>
+_appname=baton
+pkgname=${_appname}-bin
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="CLI / TUI to remotely manage Spotify playback"
+provides=("${_appname}")
+arch=('x86_64')
+url="https://github.com/joshuathompson/${_appname}"
+license=('MIT')
+source=(
+ "${pkgname}-${pkgver}::https://github.com/joshuathompson/${_appname}/releases/download/${pkgver}/${_appname}_linux_amd64"
+ "LICENSE::https://raw.githubusercontent.com/joshuathompson/${_appname}/master/LICENSE"
+)
+sha256sums=('f508f036eeea1f1eb8a2bc8df5f12b47daefa3094a8d14e1197fd00a28beb46a'
+ '3eec9c2f5c8f98f1875dbc57b9a2985313c869456466e09152259a7090f61d20')
+options=(!strip)
+
+package() {
+ install -Dm755 ../${pkgname}-${pkgver} "${pkgdir}/usr/bin/${_appname}"
+ install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et ai: