summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Erik Rediger2015-06-09 16:15:30 +0200
committerJan-Erik Rediger2015-06-09 16:15:30 +0200
commit83ffc37d16071d2a730fc1df6bd1549083d11a0d (patch)
tree5354a9cc30f68c84490c41a731896e7691e5b970
downloadaur-83ffc37d16071d2a730fc1df6bd1549083d11a0d.tar.gz
First commit in new AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ee1add74ba3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bats-git
+ pkgdesc = Bash Automated Testing System
+ pkgver = v0.4.0
+ pkgrel = 1
+ url = https://github.com/sstephenson/bats
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = bash
+ source = git+https://github.com/sstephenson/bats.git
+ md5sums = SKIP
+
+pkgname = bats-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08a069f674ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jan-Erik Rediger <badboy at archlinux dot us>
+
+pkgname=bats-git
+pkgver=v0.4.0
+pkgrel=1
+pkgdesc="Bash Automated Testing System"
+arch=("any")
+url="https://github.com/sstephenson/bats"
+license=("MIT")
+depends=('bash')
+makedepends=('git')
+source=('git+https://github.com/sstephenson/bats.git')
+md5sums=('SKIP')
+
+_gitname='bats'
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --tags | sed 's/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ #./install.sh "$pkgdir/usr"
+
+ for fn in libexec/*; do
+ install -Dm755 ${fn} \
+ ${pkgdir}/usr/lib/${_gitname}/$(basename ${fn})
+ done
+
+ install -dm755 ${pkgdir}/usr/bin
+ ln -s ../lib/${_gitname}/bats ${pkgdir}/usr/bin/bats
+ install -Dm744 man/bats.1 "${pkgdir}/usr/share/man/man1/bats.1"
+ install -Dm744 man/bats.7 "${pkgdir}/usr/share/man/man7/bats.7"
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}