summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2018-11-18 22:25:56 -0500
committerCorey Hinshaw2018-11-18 22:25:56 -0500
commitda280dc5bb6875d3eac33c99f97a7988a23f807a (patch)
tree6e4f0c8764ff919be3fb859712ca3579632d4ba1
downloadaur-da280dc5bb6875d3eac33c99f97a7988a23f807a.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7657f41c44a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = batsignal
+ pkgdesc = A lightweight battery monitor daemon
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/electrickite/batsignal
+ arch = any
+ license = ISC
+ depends = libnotify
+ source = https://github.com/electrickite/batsignal/archive/0.2.0.tar.gz
+ sha256sums = 8833664cb79ee7d0e9d21454fab23a2147ea5deee848822b13e4515279bd09a3
+
+pkgname = batsignal
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0cced017d91a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f56e261b10df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Corey Hinshaw <coreyhinshaw(at)gmail(dot)com>
+
+pkgname=batsignal
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A lightweight battery monitor daemon"
+arch=("any")
+url="https://github.com/electrickite/${pkgname%-git}"
+license=("ISC")
+depends=("libnotify")
+source=("https://github.com/electrickite/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=("8833664cb79ee7d0e9d21454fab23a2147ea5deee848822b13e4515279bd09a3")
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+}