summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNichlas Severinsen2019-04-21 14:15:59 +0200
committerNichlas Severinsen2019-04-21 14:15:59 +0200
commit90f17e756d896eddbde71cdba5f9262f485c0c0c (patch)
treeb16fbfd78320c98846ecf11627f15d1ad915a97f
downloadaur-90f17e756d896eddbde71cdba5f9262f485c0c0c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e3be0e0d3e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = battery
+ pkgdesc = Build System and Package Manager for the Volt Programming Language
+ pkgver = 0.1.20
+ pkgrel = 1
+ arch = x86
+ arch = x86_64
+ license = BSL
+ source = https://www.boost.org/LICENSE_1_0.txt
+ sha256sums = c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566
+ source_x86 = https://github.com/VoltLang/Battery/releases/download/v0.1.20/battery-0.1.20-x86-linux.tar.gz
+ sha256sums_x86 = 160f292fe35416fe037b3d3d9e0460cb2f1ac9c1347e2a7c3c08ea281a759d2f
+ source_x86_64 = https://github.com/VoltLang/Battery/releases/download/v0.1.20/battery-0.1.20-x86_64-linux.tar.gz
+ sha256sums_x86_64 = 7775ac99b6db2448e9f0757476ff826722746ab707dc2f34d500408253b9dbf0
+
+pkgname = battery
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f84dab8ba7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Nichlas Severinsen <ns@nsz.no>
+pkgname=battery
+pkgver=0.1.20
+pkgrel=1
+pkgdesc="Build System and Package Manager for the Volt Programming Language"
+arch=("x86" "x86_64")
+license=("BSL")
+
+source=("https://www.boost.org/LICENSE_1_0.txt")
+source_x86=("https://github.com/VoltLang/Battery/releases/download/v${pkgver}/battery-${pkgver}-x86-linux.tar.gz")
+source_x86_64=("https://github.com/VoltLang/Battery/releases/download/v${pkgver}/battery-${pkgver}-x86_64-linux.tar.gz")
+
+sha256sums=("c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566")
+sha256sums_x86=("160f292fe35416fe037b3d3d9e0460cb2f1ac9c1347e2a7c3c08ea281a759d2f")
+sha256sums_x86_64=("7775ac99b6db2448e9f0757476ff826722746ab707dc2f34d500408253b9dbf0")
+
+package() {
+ install -Dm755 "${srcdir}/battery" "${pkgdir}/usr/bin/battery"
+ install -Dm644 "${srcdir}/LICENSE_1_0.txt" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+} \ No newline at end of file