summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsrael Roldan2020-09-28 13:03:29 -0500
committerIsrael Roldan2020-09-28 13:03:29 -0500
commit55bd9449683518a13d23e7d2646b9d7188db8abd (patch)
tree9950e108d2716eeaf5e71684906da661015659ae
parent6f33eb9caf0a8477c42b22f8b18f4b886d831694 (diff)
downloadaur-55bd9449683518a13d23e7d2646b9d7188db8abd.tar.gz
Improved the upload script, it make the package locally then deleted the generated files after it do the upload process.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xupload-package.sh24
-rwxr-xr-xupload-pakage.sh10
4 files changed, 26 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 373935d0310b..b7a0ade5990f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = battery-discharging-beep-git
pkgdesc = Generate a sound when the battery is discharging.
- pkgver = v1.0.r0.g1c67673
+ pkgver = v1.0.r1.gb55d021
pkgrel = 1
url = https://github.com/airvzxf/linux-battery-discharging-beep.git
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9fff00d64170..af50ddb17bb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=battery-discharging-beep
_git_project=linux-"${_name}"
pkgname="${_name}"-git
-pkgver=v1.0.r0.g1c67673
+pkgver=v1.0.r1.gb55d021
pkgrel=1
pkgdesc="Generate a sound when the battery is discharging."
arch=(x86_64)
diff --git a/upload-package.sh b/upload-package.sh
new file mode 100755
index 000000000000..06784882838b
--- /dev/null
+++ b/upload-package.sh
@@ -0,0 +1,24 @@
+#!/bin/bash
+
+# Steps:
+# First in the main project / git repository needs to create an annotated tag and push it.
+# - git tag -a v1.1 -m "Release version 1.1. Upgraded all the features with dark colors."
+# - git push origin --tags
+# Then go outside of this project folder and clone the next repository after this run this script.
+# - git clone ssh://aur@aur.archlinux.org/battery-discharging-beep-git.git
+# - cd battery-discharging-beep-git
+# - ./upload-package.sh
+# If you are in the AUR repository from your local computer and you don't know what files are needed, download these:
+# - https://raw.githubusercontent.com/airvzxf/linux-battery-discharging-beep/master/arch-aur/PKGBUILD
+# - https://raw.githubusercontent.com/airvzxf/linux-battery-discharging-beep/master/arch-aur/upload-package.sh
+# - ./upload-package.sh
+
+makepkg -f
+rm -fR battery-discharging-beep* pkg src .SRCINFO
+makepkg --printsrcinfo > .SRCINFO
+git add .
+git status
+echo "Write your commit comment: "
+read -r COMMENT
+git commit -m "${COMMENT}"
+git push
diff --git a/upload-pakage.sh b/upload-pakage.sh
deleted file mode 100755
index 24110089648c..000000000000
--- a/upload-pakage.sh
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/bash
-
-# git clone ssh://aur@aur.archlinux.org/battery-discharging-beep-git.git
-makepkg --printsrcinfo > .SRCINFO
-git add .
-git status
-echo "Write your commit comment: "
-read -r COMMENT
-git commit -m "${COMMENT}"
-git push