summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Glancy2016-08-05 19:05:11 +0100
committerJoe Glancy2016-08-05 19:05:11 +0100
commit7e2f30f44744bf3ef3e334b9028cbd26eccbae8f (patch)
tree522367fd9b14eda262f29d868d7416b2aea88955
downloadaur-7e2f30f44744bf3ef3e334b9028cbd26eccbae8f.tar.gz
First commit - added PKGBUILD and .SRCINFO files
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a6136a36f36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = batteryinfo
+ pkgdesc = A simple battery status and information tool for Linux systems.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/JoeGlancy/batteryinfo
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ source = git://github.com/JoeGlancy/batteryinfo.git
+ md5sums = SKIP
+
+pkgname = batteryinfo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eee3c8ef6ab5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# batteryinfo PKGBUILD
+# Maintainer: Joe Glancy <joe.glancy.dev@gmail.com>
+pkgname=batteryinfo
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A simple battery status and information tool for Linux systems."
+arch=('i686' 'x86_64')
+url="https://github.com/JoeGlancy/batteryinfo"
+license=('GPL3')
+makedepends=('git')
+source=('git://github.com/JoeGlancy/batteryinfo.git')
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/batteryinfo"
+ make DESTDIR=/usr batteryinfo batteryinfo.1.gz
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/usr" install
+}