summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2018-11-21 10:00:42 +0100
committerAlexander F. Rødseth2018-11-21 10:00:42 +0100
commit446440dc124c391290e56ee6a51507709be81a2d (patch)
tree86a593b8c224b9f2a8e79b1e5c9965fea37064a7
parent133b82fb64a1fe674d4e4f629bd0bce44eb26e58 (diff)
downloadaur-446440dc124c391290e56ee6a51507709be81a2d.tar.gz
Update to latest version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 22 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da2801514224..90ce8bed3d9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
+# Generated by mksrcinfo v8
+# Wed Nov 21 09:00:16 UTC 2018
pkgbase = battlestar
pkgdesc = Programming language for creating tiny executables
- pkgver = 0.51
+ pkgver = 0.6.1
pkgrel = 1
- url = http://github.com/xyproto/battlestar
+ url = https://github.com/xyproto/battlestar
arch = x86_64
- arch = i686
license = MIT
- makedepends = go
+ makedepends = go-pie
makedepends = git
depends = yasm
depends = gcc
@@ -14,7 +15,7 @@ pkgbase = battlestar
optdepends = dosbox: for running 16-bit programs
optdepends = qemu-arch-extra: for running bootable kernels
optdepends = nasm: for ndisasm and com2bts
- source = git+https://github.com/xyproto/battlestar.git#tag=0.51
+ source = git+https://github.com/xyproto/battlestar.git#tag=0.6.1
md5sums = SKIP
pkgname = battlestar
diff --git a/PKGBUILD b/PKGBUILD
index 7b01bd30d3b9..f5e8ae17c2fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,43 @@
-# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=battlestar
-pkgver=0.51
+pkgver=0.6.1
pkgrel=1
pkgdesc='Programming language for creating tiny executables'
-arch=('x86_64' 'i686')
-url='http://github.com/xyproto/battlestar'
+arch=('x86_64')
+url='https://github.com/xyproto/battlestar'
license=('MIT')
-makedepends=('go' 'git')
+makedepends=('go-pie' 'git')
depends=('yasm' 'gcc')
optdepends=('elfkickers: for smaller executables'
'dosbox: for running 16-bit programs'
'qemu-arch-extra: for running bootable kernels'
'nasm: for ndisasm and com2bts')
-source=("git+https://github.com/xyproto/battlestar.git#tag=$pkgver")
+source=("git+$url.git#tag=$pkgver")
md5sums=('SKIP')
build() {
- make -C "$pkgname"
+ cd $pkgname/src
+ go build \
+ -gcflags "all=-trimpath=$PWD" \
+ -asmflags "all=-trimpath=$PWD" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o battlestarc .
+ make -C ..
}
package() {
cd "$pkgname"
- make install DESTDIR="$pkgdir"
+ make DESTDIR="$pkgdir" install
install -d "$pkgdir/usr/share/doc/$pkgname"
cp -r samples "$pkgdir/usr/share/doc/$pkgname/"
cp -r samples64 "$pkgdir/usr/share/doc/$pkgname/"
cp -r samples32 "$pkgdir/usr/share/doc/$pkgname/"
cp -r samples16 "$pkgdir/usr/share/doc/$pkgname/"
cp -r helloworld "$pkgdir/usr/share/doc/$pkgname/"
- install -Dm644 tutorial.md "$pkgdir/usr/share/doc/$pkgname/tutorial.md"
+ install -Dm644 TUTORIAL.md "$pkgdir/usr/share/doc/$pkgname/TUTORIAL.md"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et