summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-07-21 15:50:01 +0200
committerAlexander F. Rødseth2022-07-21 15:50:01 +0200
commit8b005997495203d91da894f3df2328978e206264 (patch)
tree5a00a08f3e8f0f4671910be95da03170bc6d0076
parent446440dc124c391290e56ee6a51507709be81a2d (diff)
downloadaur-8b005997495203d91da894f3df2328978e206264.tar.gz
New minor release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 18 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90ce8bed3d9f..bdf650fdbf0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
-# Generated by mksrcinfo v8
-# Wed Nov 21 09:00:16 UTC 2018
pkgbase = battlestar
pkgdesc = Programming language for creating tiny executables
- pkgver = 0.6.1
+ pkgver = 0.7.0
pkgrel = 1
url = https://github.com/xyproto/battlestar
arch = x86_64
- license = MIT
- makedepends = go-pie
+ license = BSD
makedepends = git
- depends = yasm
+ makedepends = go
depends = gcc
+ depends = yasm
optdepends = elfkickers: for smaller executables
optdepends = dosbox: for running 16-bit programs
- optdepends = qemu-arch-extra: for running bootable kernels
optdepends = nasm: for ndisasm and com2bts
- source = git+https://github.com/xyproto/battlestar.git#tag=0.6.1
- md5sums = SKIP
+ optdepends = qemu-arch-extra: for running bootable kernels
+ source = git+https://github.com/xyproto/battlestar#commit=deb78a26b141531abe6cdc5cd980691e3a41ec46
+ b2sums = SKIP
pkgname = battlestar
-
diff --git a/PKGBUILD b/PKGBUILD
index f5e8ae17c2fc..63e4b14dec0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,27 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=battlestar
-pkgver=0.6.1
+pkgver=0.7.0
pkgrel=1
pkgdesc='Programming language for creating tiny executables'
-arch=('x86_64')
+arch=(x86_64)
url='https://github.com/xyproto/battlestar'
-license=('MIT')
-makedepends=('go-pie' 'git')
-depends=('yasm' 'gcc')
+license=(BSD)
+makedepends=(git go)
+depends=(gcc yasm)
optdepends=('elfkickers: for smaller executables'
'dosbox: for running 16-bit programs'
- 'qemu-arch-extra: for running bootable kernels'
- 'nasm: for ndisasm and com2bts')
-source=("git+$url.git#tag=$pkgver")
-md5sums=('SKIP')
+ 'nasm: for ndisasm and com2bts'
+ 'qemu-arch-extra: for running bootable kernels')
+source=("git+$url#commit=deb78a26b141531abe6cdc5cd980691e3a41ec46")
+b2sums=('SKIP')
build() {
- cd $pkgname/src
- go build \
- -gcflags "all=-trimpath=$PWD" \
- -asmflags "all=-trimpath=$PWD" \
- -ldflags "-extldflags $LDFLAGS" \
- -o battlestarc .
- make -C ..
+ make -C $pkgname
}
package() {
- cd "$pkgname"
-
+ cd $pkgname
make DESTDIR="$pkgdir" install
install -d "$pkgdir/usr/share/doc/$pkgname"
cp -r samples "$pkgdir/usr/share/doc/$pkgname/"
@@ -39,5 +32,3 @@ package() {
install -Dm644 TUTORIAL.md "$pkgdir/usr/share/doc/$pkgname/TUTORIAL.md"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim: ts=2 sw=2 et