summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuoi2023-02-11 02:50:10 +0800
committerKuoi2023-02-11 02:50:10 +0800
commiteb8ba5e35d6214fb9776198f00faec485308df30 (patch)
tree0d78d14b1dacd4b6fa8871a9b17e60e8b710cf7e
downloadaur-eb8ba5e35d6214fb9776198f00faec485308df30.tar.gz
bayarea: init
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1fb08d38708e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bayarea
+ pkgdesc = Bayesian inference of historical biogeography for many discrete areas https://doi.org/10.1093/sysbio/syt040
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/mlandis/bayarea
+ arch = x86_64
+ license = MIT
+ makedepends = gcc
+ makedepends = git
+ source = git+https://github.com/mlandis/bayarea.git
+ md5sums = SKIP
+
+pkgname = bayarea
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6858457e7ad5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=bayarea
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Bayesian inference of historical biogeography for many discrete areas https://doi.org/10.1093/sysbio/syt040"
+arch=('x86_64')
+url="https://github.com/mlandis/bayarea"
+license=('MIT')
+makedepends=('gcc' 'git')
+source=("git+$url.git")
+md5sums=('SKIP')
+pkgver(){
+ cd "$pkgname"/code
+ printf $(grep 'BayArea ' main.cpp | sed 's@v@@g' | sed 's/\\n\"/ /g' | awk '{print $4}')
+}
+build(){
+ cd $pkgname/code
+ g++ -O3 *.cpp -o $pkgname
+}
+
+package() {
+ cd $pkgname/code
+ chmod +x $pkgname
+ install -Dm 755 $pkgname $pkgdir/usr/bin/$pkgname
+}