aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
author4s3ti2024-02-23 01:14:48 +0100
committer4s3ti2024-02-23 01:14:48 +0100
commitd4dd0decd492671a6ccc91aeda727a326202ca49 (patch)
tree9de04b0d7cb7a38caad09d0c450ea02a02f5b7c9
downloadaur-d4dd0decd492671a6ccc91aeda727a326202ca49.tar.gz
Init
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--10-dygma.rules4
-rw-r--r--PKGBUILD54
-rw-r--r--README.md10
-rw-r--r--precommit.sh2
6 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91fee22ffdf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bazecor
+ pkgdesc = Graphical configurator for Dygma keyboards
+ pkgver = 1.4.0.rc.1
+ pkgrel = 1
+ url = https://github.com/Dygmalab/Bazecor
+ arch = x86_64
+ license = GPL-3.0-only
+ depends = zlib
+ depends = fuse2
+ provides = bazecor
+ conflicts = bazecor-git
+ noextract = Bazecor-1.4.0-rc.1-x64.AppImage
+ options = !strip
+ source = https://github.com/Dygmalab/Bazecor/releases/download/v1.4.0-rc.1/Bazecor-1.4.0-rc.1-x64.AppImage
+ source = 10-dygma.rules
+ sha256sums = c6cee84c10a531ddbc8f3ad1dfc6a6bb8f286c280772827177fecfe7a7871d67
+ sha256sums = 7cc39c4fdc1736c267d22d9fbaacc9db4afd026c3a77b1d263c3a11b65581def
+
+pkgname = bazecor
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..78938136f41a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.zst
+pkg/
+src/
+*.AppImage
diff --git a/10-dygma.rules b/10-dygma.rules
new file mode 100644
index 000000000000..6805e68c0644
--- /dev/null
+++ b/10-dygma.rules
@@ -0,0 +1,4 @@
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="1209", ATTRS{idProduct}=="2201", MODE="0666"
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="1209", ATTRS{idProduct}=="2200", MODE="0666"
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="35ef", MODE="0666"
+KERNEL=="hidraw*", ATTRS{idVendor}=="35ef", MODE="0666"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68f3da7607f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: 4s3ti <4s3ti@4s3ti.net>
+
+_pkgver=1.4.0-rc.1
+_appimage="Bazecor-${_pkgver}-x64.AppImage"
+
+pkgname="bazecor"
+pkgver=${_pkgver/-/.}
+pkgrel=1
+pkgdesc="Graphical configurator for Dygma keyboards"
+url="https://github.com/Dygmalab/Bazecor"
+license=("GPL-3.0-only")
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+arch=("x86_64")
+depends=('zlib' 'fuse2')
+options=(!strip)
+noextract=("${_appimage}")
+source=("${url}/releases/download/v${_pkgver}/${_appimage}"
+ "10-dygma.rules")
+sha256sums=('c6cee84c10a531ddbc8f3ad1dfc6a6bb8f286c280772827177fecfe7a7871d67'
+ '7cc39c4fdc1736c267d22d9fbaacc9db4afd026c3a77b1d263c3a11b65581def')
+
+prepare() {
+ chmod +x "${_appimage}"
+ "./${_appimage}" --appimage-extract
+}
+
+build() {
+ # Adjust .desktop so it will work outside of AppImage container
+ sed -i -E "s|Exec=AppRun|Exec=env DESKTOPINTEGRATION=false /usr/bin/${pkgname/b/B}|"\
+ "squashfs-root/${pkgname/b/B}.desktop"
+ # Fix permissions; .AppImage permissions are 700 for all directories
+ chmod -R a-x+rX squashfs-root/usr
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/${pkgname}/${_appimage}"
+
+ # Desktop file
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname/b/B}.desktop"\
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Icon images
+ install -dm755 "${pkgdir}/usr/share/"
+ cp -a "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
+
+ # Symlink executable
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/${_appimage}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Udev Rules
+ # https://github.com/Dygmalab/Bazecor/blob/development/src/main/utils/udev.ts#L6C1-L6C284
+ install -Dm644 "${srcdir}/10-dygma.rules" "${pkgdir}/etc/udev/rules.d/10-dygma.rules"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..fe1780e8e348
--- /dev/null
+++ b/README.md
@@ -0,0 +1,10 @@
+# Bazecor AUR package
+
+Installs bazecore stable releases
+
+## WAYLAND Users
+
+you may need to execute with the following flags
+
+`--UseOzonePlatform --ozone-platform-hint=wayland`
+
diff --git a/precommit.sh b/precommit.sh
new file mode 100644
index 000000000000..e3ff371b37da
--- /dev/null
+++ b/precommit.sh
@@ -0,0 +1,2 @@
+updpkgsums
+makepkg --printsrcinfo > .SRCINFO