summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenneth Endfinger2020-01-15 04:13:58 -0500
committerKenneth Endfinger2020-01-15 04:13:58 -0500
commit50c8e3655840708c7ef2fcdf5621cd5d39a949f6 (patch)
treec3d8d3ebcef7ab51d8852199869065d10d4e6a7b
downloadaur-50c8e3655840708c7ef2fcdf5621cd5d39a949f6.tar.gz
Initial Commit
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD33
-rwxr-xr-xcheck-for-update.sh17
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4b510b20b0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = bazel-bootstrap
+ pkgdesc = (Bootstrap Build) Correct, reproducible, and fast builds for everyone
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://bazel.io/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = Apache
+ makedepends = git
+ makedepends = protobuf
+ makedepends = python
+ depends = java-environment=11
+ depends = libarchive
+ depends = zip
+ depends = unzip
+ options = !distcc
+ options = !strip
+ options = !ccache
+ source = bazel-bootstrap.zip::https://github.com/bazelbuild/bazel/releases/download/2.0.0/bazel-2.0.0-dist.zip
+ source = bazel-bootstrap.zip.sig::https://github.com/bazelbuild/bazel/releases/download/2.0.0/bazel-2.0.0-dist.zip.sig
+ validpgpkeys = 71A1D0EFCFEB6281FD0437C93D5919B448457EE0
+ sha512sums = db609e9d0ee0cdbfb999de850db17907af02dc26e605f4617dfeb2fbac5c30c4c0a9f48c6ba3673ffe8babb5b9e157cc51c32832015b85ed279b6b160506cdae
+ sha512sums = SKIP
+
+pkgname = bazel-bootstrap
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9e7de4264dad
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/src
+/pkg
+*.xz
+*.tar.*
+*.pkg.*
+*.zip
+*.zip.sig
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0195d11b6fc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Kenneth Endfinger <kaendfinger@gmail.com>
+pkgname=bazel-bootstrap
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="(Bootstrap Build) Correct, reproducible, and fast builds for everyone"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="http://bazel.io/"
+license=('Apache')
+depends=('java-environment=11' 'libarchive' 'zip' 'unzip')
+makedepends=('git' 'protobuf' 'python')
+options=('!distcc' '!strip' '!ccache')
+source=("bazel-bootstrap.zip::https://github.com/bazelbuild/bazel/releases/download/${pkgver}/bazel-${pkgver}-dist.zip"
+ "bazel-bootstrap.zip.sig::https://github.com/bazelbuild/bazel/releases/download/${pkgver}/bazel-${pkgver}-dist.zip.sig"
+)
+
+sha512sums=('db609e9d0ee0cdbfb999de850db17907af02dc26e605f4617dfeb2fbac5c30c4c0a9f48c6ba3673ffe8babb5b9e157cc51c32832015b85ed279b6b160506cdae'
+ 'SKIP')
+validpgpkeys=('71A1D0EFCFEB6281FD0437C93D5919B448457EE0')
+
+build() {
+ env EXTRA_BAZEL_ARGS="--host_javabase=@local_jdk//:jdk" ./compile.sh
+ cd output
+ ./bazel shutdown
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt/bazel-bootstrap/bin"
+ install -Dm755 "${srcdir}/scripts/packages/bazel.sh" "${pkgdir}/opt/bazel-bootstrap/bin/bazel"
+ install -Dm755 "${srcdir}/output/bazel" "${pkgdir}/opt/bazel-bootstrap/bin/bazel-real"
+ for d in examples third_party tools; do
+ cp -r "${srcdir}/${d}" "${pkgdir}/opt/bazel-bootstrap/"
+ done
+}
diff --git a/check-for-update.sh b/check-for-update.sh
new file mode 100755
index 000000000000..97cf29690e75
--- /dev/null
+++ b/check-for-update.sh
@@ -0,0 +1,17 @@
+#!/usr/bin/env bash
+set -e
+
+cd $(dirname "${0}")
+
+REPOSITORY="bazelbuild/bazel"
+
+PKG=$(cat .SRCINFO | grep "pkgbase" | head -n1 | awk '{print $3}')
+CURRENT=$(cat .SRCINFO | grep "pkgver" | head -n1 | awk '{print $3}')
+LATEST=$(curl --silent -L "https://api.github.com/repos/${REPOSITORY}/tags" | jq -r '.[].name' | grep -v -- "-" | grep -v "^v" | grep "\." | head -n1)
+if [ "${LATEST}" != "${CURRENT}" ]
+then
+ echo "${PKG} : AUR ${CURRENT} != GitHub ${LATEST}"
+ exit 1
+fi
+echo "${PKG} : AUR ${CURRENT} == GitHub ${LATEST}"
+exit 0