summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc Plano-Lesay2020-03-11 20:27:58 +1100
committerMarc Plano-Lesay2020-03-11 20:27:58 +1100
commit25deb5e2d915546ca5aae963ce17ad80bdab649d (patch)
tree69f92786a824db058253458467ac83ef45f83087
parent1ab1475a33bd477fbf2842c86428527f71bb6021 (diff)
downloadaur-25deb5e2d915546ca5aae963ce17ad80bdab649d.tar.gz
upgpkg: bazel-buildtools 2.2.0-2
Switch bazel-buildtools from binaries to building them. This package should have been called bazel-buildtools-bin if it was just extracting binaries, and this should also fix the naming conflicts on upgrade.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4a7848f2212..2514f20a7937 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = bazel-buildtools
pkgdesc = Developer tools for working with Google's bazel buildtool.
pkgver = 2.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bazelbuild/buildtools
arch = x86_64
license = Apache
- optdepends = bazel: the build tool to work with
- source = https://github.com/bazelbuild/buildtools/releases/download/2.2.0/buildifier
- source = https://github.com/bazelbuild/buildtools/releases/download/2.2.0/buildozer
- source = https://github.com/bazelbuild/buildtools/releases/download/2.2.0/unused_deps
- sha256sums = 4a1f6d5388175ed4ef41376b0532917e2bc179318921ad01d8d0edf7b09ec603
- sha256sums = 1fec52159253694e012ec1ce81675a8b8118abf04b40825c27f26fa920bd4bbc
- sha256sums = 2c2a8774730e71a0303b618f2ee56d97330b6e8f7704a206e5ffa1be71c7c9ca
+ makedepends = bazel
+ makedepends = git
+ source = https://github.com/bazelbuild/buildtools/archive/2.2.0.tar.gz
+ sha256sums = 069617be63d72c2c70a14d832102a98d65fe12e02661f7c42797bc390c80017f
pkgname = bazel-buildtools
diff --git a/PKGBUILD b/PKGBUILD
index 9560b1b6a34b..fe34ffba9ac3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,24 @@
pkgname=bazel-buildtools
pkgver=2.2.0
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://github.com/bazelbuild/buildtools'
license=('Apache')
pkgdesc="Developer tools for working with Google's bazel buildtool."
-optdepends=('bazel: the build tool to work with')
-source=("https://github.com/bazelbuild/buildtools/releases/download/$pkgver/buildifier"
- "https://github.com/bazelbuild/buildtools/releases/download/$pkgver/buildozer"
- "https://github.com/bazelbuild/buildtools/releases/download/$pkgver/unused_deps")
+makedepends=("bazel" "git")
+
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=("069617be63d72c2c70a14d832102a98d65fe12e02661f7c42797bc390c80017f")
+
+build() {
+ cd buildtools-$pkgver
+ bazel build //buildifier //buildozer //unused_deps
+}
+
package() {
+ cd buildtools-$pkgver
install -d "$pkgdir"/usr/bin
- install -Dm755 buildifier buildozer unused_deps $pkgdir/usr/bin/
+ install -Dm755 bazel-bin/buildifier/*/buildifier bazel-bin/buildozer/*/buildozer bazel-bin/unused_deps/*/unused_deps $pkgdir/usr/bin/
}
-sha256sums=('4a1f6d5388175ed4ef41376b0532917e2bc179318921ad01d8d0edf7b09ec603'
- '1fec52159253694e012ec1ce81675a8b8118abf04b40825c27f26fa920bd4bbc'
- '2c2a8774730e71a0303b618f2ee56d97330b6e8f7704a206e5ffa1be71c7c9ca')