summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiang Gao2018-03-15 16:24:00 -0400
committerXiang Gao2018-03-15 16:24:00 -0400
commitead2bfde872ff8724c904e4f838181f2c994faf9 (patch)
treed560df47212a9ba82adaf97781e7cc8bff42e404
downloadaur-ead2bfde872ff8724c904e4f838181f2c994faf9.tar.gz
v0.11.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1adbefd167f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bazel-buildtools
+ pkgdesc = Developer tools for working with Google's bazel buildtool.
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = https://github.com/bazelbuild/buildtools
+ arch = x86_64
+ license = Apache
+ optdepends = bazel: the build tool to work with
+ source = https://github.com/bazelbuild/buildtools/releases/download/0.11.1/buildifier
+ source = https://github.com/bazelbuild/buildtools/releases/download/0.11.1/buildozer
+ source = https://github.com/bazelbuild/buildtools/releases/download/0.11.1/unused_deps
+ md5sums = 20bd6625605b44fc67820c3e175192fb
+ md5sums = f1e85ee5d83cd19ab2ec5281ad8246c9
+ md5sums = b42cc398eca7d59bdc80e77408d12236
+
+pkgname = bazel-buildtools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4049b15b5982
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Xiang Gao <qasdfgtyuiop at gmail dot com>
+
+pkgname=bazel-buildtools
+pkgver=0.11.1
+pkgrel=1
+arch=('x86_64')
+url='https://github.com/bazelbuild/buildtools'
+license=('Apache')
+pkgdesc="Developer tools for working with Google's bazel buildtool."
+optdepends=('bazel: the build tool to work with')
+source=("https://github.com/bazelbuild/buildtools/releases/download/$pkgver/buildifier"
+ "https://github.com/bazelbuild/buildtools/releases/download/$pkgver/buildozer"
+ "https://github.com/bazelbuild/buildtools/releases/download/$pkgver/unused_deps")
+package() {
+ install -d "$pkgdir"/usr/bin
+ install -Dm755 buildifier buildozer unused_deps $pkgdir/usr/bin/
+}
+md5sums=('20bd6625605b44fc67820c3e175192fb'
+ 'f1e85ee5d83cd19ab2ec5281ad8246c9'
+ 'b42cc398eca7d59bdc80e77408d12236')