summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-04-25 15:16:54 +0200
committerMichel Zou2020-04-25 15:16:54 +0200
commit4920092c9e217fd08ce0404993bfab37654d36c6 (patch)
treef4d17551d45711f18508a3c6a0b17dc2cb2940cf
downloadaur-bazel024.tar.gz
0.24.1
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD46
-rw-r--r--grpc_rename_gettid.patch78
3 files changed, 152 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d01bfea3cc0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = bazel024
+ pkgdesc = Correct, reproducible, and fast builds for everyone
+ pkgver = 0.24.1
+ pkgrel = 1
+ url = https://bazel.io/
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = protobuf
+ makedepends = python
+ depends = java-environment=11
+ depends = libarchive
+ depends = zip
+ depends = unzip
+ provides = bazel=0.24.1
+ conflicts = bazel
+ options = !distcc
+ options = !strip
+ source = https://github.com/bazelbuild/bazel/releases/download/0.24.1/bazel-0.24.1-dist.zip
+ source = https://github.com/bazelbuild/bazel/releases/download/0.24.1/bazel-0.24.1-dist.zip.sig
+ source = grpc_rename_gettid.patch
+ validpgpkeys = 71A1D0EFCFEB6281FD0437C93D5919B448457EE0
+ sha512sums = a78c871eb517ec53a0d1d9592887288fa54e5e9f44b0b7dba44792a74a1ba0c98e38ff2f6094ab6e8b3add3ec4a0188de3b2489d94d419373e210d16db641774
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = bazel024
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7ec03559a94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+pkgname=bazel024
+pkgver=0.24.1
+pkgrel=1
+pkgdesc='Correct, reproducible, and fast builds for everyone'
+arch=('x86_64')
+license=('Apache')
+url='https://bazel.io/'
+depends=('java-environment=11' 'libarchive' 'zip' 'unzip')
+makedepends=('git' 'protobuf' 'python')
+provides=("bazel=${pkgver}")
+conflicts=('bazel')
+options=('!distcc' '!strip')
+source=("https://github.com/bazelbuild/bazel/releases/download/${pkgver}/bazel-${pkgver}-dist.zip"
+ "https://github.com/bazelbuild/bazel/releases/download/${pkgver}/bazel-${pkgver}-dist.zip.sig"
+ grpc_rename_gettid.patch)
+sha512sums=('a78c871eb517ec53a0d1d9592887288fa54e5e9f44b0b7dba44792a74a1ba0c98e38ff2f6094ab6e8b3add3ec4a0188de3b2489d94d419373e210d16db641774'
+ 'SKIP' 'SKIP')
+validpgpkeys=('71A1D0EFCFEB6281FD0437C93D5919B448457EE0')
+
+prepare () {
+ # https://github.com/bazelbuild/bazel/issues/9391
+ curl -L https://github.com/bazelbuild/bazel/commit/b8e1bb18fae89898b0d28535c6355e67b7d4239e.patch | patch -p1
+ curl -L https://github.com/bazelbuild/bazel/pull/9394.patch | patch -p1
+
+ # https://github.com/bazelbuild/bazel/issues/8666
+ pushd third_party/grpc && patch -p0 -i "$srcdir/grpc_rename_gettid.patch"
+}
+
+build() {
+ env EXTRA_BAZEL_ARGS="--host_javabase=@local_jdk//:jdk" ./compile.sh
+ ./output/bazel build scripts:bazel-complete.bash
+ cd output
+ ./bazel shutdown
+}
+
+package() {
+ install -Dm755 "${srcdir}/scripts/packages/bazel.sh" "${pkgdir}/usr/bin/bazel"
+ install -Dm755 "${srcdir}/output/bazel" "${pkgdir}/usr/bin/bazel-real"
+ install -Dm644 "${srcdir}/bazel-bin/scripts/bazel-complete.bash" "${pkgdir}/usr/share/bash-completion/completions/bazel"
+ install -Dm644 "${srcdir}/scripts/zsh_completion/_bazel" "${pkgdir}/usr/share/zsh/site-functions/_bazel"
+ mkdir -p "${pkgdir}/opt/bazel"
+ for d in examples third_party tools; do
+ cp -r "${srcdir}/${d}" "${pkgdir}/opt/bazel/"
+ done
+}
+# vim:set ts=2 sw=2 et:
diff --git a/grpc_rename_gettid.patch b/grpc_rename_gettid.patch
new file mode 100644
index 000000000000..9b3cafe29816
--- /dev/null
+++ b/grpc_rename_gettid.patch
@@ -0,0 +1,78 @@
+From d1d017390b799c59d6fdf7b8afa6136d218bdd61 Mon Sep 17 00:00:00 2001
+From: Benjamin Peterson <benjamin@dropbox.com>
+Date: Fri, 3 May 2019 08:11:00 -0700
+Subject: [PATCH] Rename gettid() functions.
+
+glibc 2.30 will declare its own gettid; see https://sourceware.org/git/?p=glibc.git;a=commit;h=1d0fc213824eaa2a8f8c4385daaa698ee8fb7c92. Rename the grpc versions to avoid naming conflicts.
+---
+ src/core/lib/gpr/log_linux.cc | 4 ++--
+ src/core/lib/gpr/log_posix.cc | 4 ++--
+ src/core/lib/iomgr/ev_epollex_linux.cc | 4 ++--
+ 3 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git src/core/lib/gpr/log_linux.cc.orig src/core/lib/gpr/log_linux.cc
+index 561276f0c20..8b597b4cf2f 100644
+--- src/core/lib/gpr/log_linux.cc.orig 2019-06-21 10:42:13.235611417 -0400
++++ src/core/lib/gpr/log_linux.cc 2019-06-21 10:42:16.686608855 -0400
+@@ -40,7 +40,7 @@
+ #include <time.h>
+ #include <unistd.h>
+
+-static long gettid(void) { return syscall(__NR_gettid); }
++static long sys_gettid(void) { return syscall(__NR_gettid); }
+
+ void gpr_log(const char* file, int line, gpr_log_severity severity,
+ const char* format, ...) {
+@@ -70,7 +70,7 @@ void gpr_default_log(gpr_log_func_args*
+ gpr_timespec now = gpr_now(GPR_CLOCK_REALTIME);
+ struct tm tm;
+ static __thread long tid = 0;
+- if (tid == 0) tid = gettid();
++ if (tid == 0) tid = sys_gettid();
+
+ timer = static_cast<time_t>(now.tv_sec);
+ final_slash = strrchr(args->file, '/');
+diff --git src/core/lib/gpr/log_posix.cc.orig src/core/lib/gpr/log_posix.cc
+index b6edc14ab6b..2f7c6ce3760 100644
+--- src/core/lib/gpr/log_posix.cc.orig 2019-06-21 10:42:13.242611412 -0400
++++ src/core/lib/gpr/log_posix.cc 2019-06-21 10:42:22.794604319 -0400
+@@ -30,7 +30,7 @@
+ #include <string.h>
+ #include <time.h>
+
+-static intptr_t gettid(void) { return (intptr_t)pthread_self(); }
++static intptr_t sys_gettid(void) { return (intptr_t)pthread_self(); }
+
+ void gpr_log(const char* file, int line, gpr_log_severity severity,
+ const char* format, ...) {
+@@ -85,7 +85,7 @@ void gpr_default_log(gpr_log_func_args*
+ char* prefix;
+ gpr_asprintf(&prefix, "%s%s.%09d %7tu %s:%d]",
+ gpr_log_severity_string(args->severity), time_buffer,
+- (int)(now.tv_nsec), gettid(), display_file, args->line);
++ (int)(now.tv_nsec), sys_gettid(), display_file, args->line);
+
+ fprintf(stderr, "%-70s %s\n", prefix, args->message);
+ gpr_free(prefix);
+diff --git src/core/lib/iomgr/ev_epollex_linux.cc.orig src/core/lib/iomgr/ev_epollex_linux.cc
+index 08116b3ab53..76f59844312 100644
+--- src/core/lib/iomgr/ev_epollex_linux.cc.orig 2019-06-21 10:42:13.247611408 -0400
++++ src/core/lib/iomgr/ev_epollex_linux.cc 2019-06-21 10:42:29.767599141 -0400
+@@ -1150,7 +1150,7 @@ static void end_worker(grpc_pollset* pol
+ }
+
+ #ifndef NDEBUG
+-static long gettid(void) { return syscall(__NR_gettid); }
++static long sys_gettid(void) { return syscall(__NR_gettid); }
+ #endif
+
+ /* pollset->mu lock must be held by the caller before calling this.
+@@ -1170,7 +1170,7 @@ static grpc_error* pollset_work(grpc_pol
+ #define WORKER_PTR (&worker)
+ #endif
+ #ifndef NDEBUG
+- WORKER_PTR->originator = gettid();
++ WORKER_PTR->originator = sys_gettid();
+ #endif
+ if (grpc_polling_trace.enabled()) {
+ gpr_log(GPR_INFO,