summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-04-25 14:35:17 +0200
committerMichel Zou2020-04-25 14:35:17 +0200
commit97aaf80a756efdef1edd730317c4f3a78cf90c6c (patch)
tree68634c237003382b7cad73dcff6c1b92c92acea0
downloadaur-97aaf80a756efdef1edd730317c4f3a78cf90c6c.tar.gz
ln
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a13ea2548fc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bazel024-bin
+ pkgdesc = Correct, reproducible, and fast builds for everyone
+ pkgver = 0.24.1
+ pkgrel = 1
+ url = https://bazel.io/
+ arch = x86_64
+ license = Apache
+ depends = java-environment=11
+ depends = libarchive
+ depends = zip
+ depends = unzip
+ provides = bazel=0.24.1
+ conflicts = bazel
+ options = !strip
+ source = https://github.com/bazelbuild/bazel/releases/download/0.24.1/bazel-0.24.1-installer-linux-x86_64.sh
+ sha256sums = cf8210e538c37f195298905301a1221ca5b6a5a6658ccd1c4369a867aa2339c3
+
+pkgname = bazel024-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ba9ecaaa5b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=bazel024-bin
+pkgver=0.24.1
+pkgrel=1
+pkgdesc='Correct, reproducible, and fast builds for everyone'
+arch=('x86_64')
+license=('Apache')
+url='https://bazel.io/'
+depends=('java-environment=11' 'libarchive' 'zip' 'unzip')
+makedepends=()
+provides=("bazel=${pkgver}")
+conflicts=('bazel')
+options=('!strip')
+source=("https://github.com/bazelbuild/bazel/releases/download/${pkgver}/bazel-${pkgver}-installer-linux-x86_64.sh")
+sha256sums=('cf8210e538c37f195298905301a1221ca5b6a5a6658ccd1c4369a867aa2339c3')
+
+package() {
+ sh bazel-${pkgver}-installer-linux-x86_64.sh --prefix="${pkgdir}/usr"
+ rm "${pkgdir}"/usr/bin/bazel
+ cd "${pkgdir}"/usr/bin && ln -s ../lib/bazel/bin/bazel bazel
+}