summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorY Nguyen2021-05-14 17:11:11 +0700
committerY Nguyen2021-05-14 17:11:11 +0700
commit8afdfcbc021430b6dae179fb52abc396090aa93f (patch)
tree9228c2e788ee31db0770c34c9830f434ff609d51
downloadaur-8afdfcbc021430b6dae179fb52abc396090aa93f.tar.gz
Add bazel 3.7.2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ca7af9e2dd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bazel3-bin
+ pkgdesc = Build and test software of any size, quickly and reliably.
+ pkgver = 3.7.2
+ pkgrel = 1
+ url = https://bazel.build
+ arch = x86_64
+ license = Apache
+ depends = java-environment=11
+ provides = bazel3
+ provides = bazel=3.7.2
+ conflicts = bazel3
+ conflicts = bazel
+ noextract = bazel_nojdk-3.7.2-linux-x86_64
+ options = !strip
+ source = https://github.com/bazelbuild/bazel/releases/download/3.7.2/bazel_nojdk-3.7.2-linux-x86_64
+ sha256sums = dbf43bf909d2dbdd428820a6794d668404edcf1e15f20475837e568c83c9cd7b
+
+pkgname = bazel3-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e29ea13e8c73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Super Bo <supernbo@gmail.com>
+pkgname=bazel3-bin
+pkgver=3.7.2
+pkgrel=1
+pkgdesc='Build and test software of any size, quickly and reliably.'
+arch=('x86_64')
+url='https://bazel.build'
+license=('Apache')
+depends=('java-environment=11')
+provides=("${pkgname%-bin}" "bazel=${pkgver}")
+conflicts=('bazel3' 'bazel')
+options=('!strip')
+source=(
+ "https://github.com/bazelbuild/bazel/releases/download/${pkgver}/bazel_nojdk-${pkgver}-linux-x86_64"
+)
+noextract=("bazel_nojdk-${pkgver}-linux-x86_64")
+sha256sums=(
+ "dbf43bf909d2dbdd428820a6794d668404edcf1e15f20475837e568c83c9cd7b"
+)
+
+package() {
+ install -Dm755 bazel_nojdk-${pkgver}-linux-x86_64 "${pkgdir}/usr/bin/bazel"
+}