summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwasertech2022-03-05 01:57:55 +0100
committerwasertech2022-03-05 01:57:55 +0100
commit25681167a6f90735fe1469f24875cfb249acf25c (patch)
tree0f96121ae371a1a784a8de83490ae3163654a3a0
parent8afdfcbc021430b6dae179fb52abc396090aa93f (diff)
downloadaur-25681167a6f90735fe1469f24875cfb249acf25c.tar.gz
initial bin commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD14
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ca7af9e2dd6..f913a731cf33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
-pkgbase = bazel3-bin
+pkgbase = bazel31-bin
pkgdesc = Build and test software of any size, quickly and reliably.
- pkgver = 3.7.2
+ pkgver = 3.1.0
pkgrel = 1
url = https://bazel.build
arch = x86_64
license = Apache
- depends = java-environment=11
- provides = bazel3
- provides = bazel=3.7.2
+ depends = java-environment=8
+ provides = bazel31
+ provides = bazel=3.1.0
+ conflicts = bazel31
+ conflicts = bazel3-bin
conflicts = bazel3
conflicts = bazel
- noextract = bazel_nojdk-3.7.2-linux-x86_64
+ noextract = bazel-3.1.0-linux-x86_64
options = !strip
- source = https://github.com/bazelbuild/bazel/releases/download/3.7.2/bazel_nojdk-3.7.2-linux-x86_64
- sha256sums = dbf43bf909d2dbdd428820a6794d668404edcf1e15f20475837e568c83c9cd7b
+ source = https://github.com/bazelbuild/bazel/releases/download/3.1.0/bazel-3.1.0-linux-x86_64
+ sha256sums = 605118766dbe07d04f4f15a809b231247eef3f302c431dcb712a514244662a47d3eb784add3b20d69d415954f7a95f9988215560911079289170a383343398d1
pkgname = bazel3-bin
diff --git a/PKGBUILD b/PKGBUILD
index e29ea13e8c73..5068ffb53719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Super Bo <supernbo@gmail.com>
-pkgname=bazel3-bin
-pkgver=3.7.2
+pkgname=bazel31-bin
+pkgver=3.1.0
pkgrel=1
pkgdesc='Build and test software of any size, quickly and reliably.'
arch=('x86_64')
url='https://bazel.build'
license=('Apache')
-depends=('java-environment=11')
+depends=('java-environment=8')
provides=("${pkgname%-bin}" "bazel=${pkgver}")
-conflicts=('bazel3' 'bazel')
+conflicts=('bazel31' 'bazel3' 'bazel3-bin' 'bazel')
options=('!strip')
source=(
- "https://github.com/bazelbuild/bazel/releases/download/${pkgver}/bazel_nojdk-${pkgver}-linux-x86_64"
+ "https://github.com/bazelbuild/bazel/releases/download/${pkgver}/bazel-${pkgver}-linux-x86_64"
)
noextract=("bazel_nojdk-${pkgver}-linux-x86_64")
sha256sums=(
- "dbf43bf909d2dbdd428820a6794d668404edcf1e15f20475837e568c83c9cd7b"
+ "605118766dbe07d04f4f15a809b231247eef3f302c431dcb712a514244662a47d3eb784add3b20d69d415954f7a95f9988215560911079289170a383343398d1"
)
package() {
- install -Dm755 bazel_nojdk-${pkgver}-linux-x86_64 "${pkgdir}/usr/bin/bazel"
+ install -Dm755 bazel-${pkgver}-linux-x86_64 "${pkgdir}/usr/bin/bazel"
}