summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2021-05-13 08:46:43 -0600
committerBenjamin Denhartog2021-05-14 07:53:26 -0600
commit07fcb95e76991ca69a67c26f0f86091e01f5b7bd (patch)
treec9cb5479cbdb2216ca28aaebcb83736c0f181401
parent4101e4b45c028d40887992f13c1ff93d98b3cd2e (diff)
downloadaur-07fcb95e76991ca69a67c26f0f86091e01f5b7bd.tar.gz
feat(bazelisk): standardize PKGBUILD files
This change brings in various changes to the PKGBUILD files in an attempt to standardize them. - Single quotes for variable values that do not include other variables - Dogfood bazelisk to avoid .bazelversion incompatibilities - Minor formatting changes - Rename license file from 'Apache 2.0' to 'Apache', as they are equal on Arch Linux systems GitOrigin-RevId: adcecf4608c54730a994084e0530e78260f3b51c
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD45
3 files changed, 37 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0f1bf9fa709..1f6af8566d39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = bazelisk
pkgdesc = A user-friendly launcher for Bazel.
pkgver = 1.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bazelbuild/bazelisk
arch = x86_64
- license = Apache 2.0
+ license = Apache
makedepends = bazel
makedepends = git
provides = bazel
conflicts = bazel
- source = https://github.com/bazelbuild/bazelisk/archive/v1.8.1.tar.gz
+ source = bazelisk-1.8.1.tar.gz::https://github.com/bazelbuild/bazelisk/archive/v1.8.1.tar.gz
+ source = bazelisk-bin-1.8.1::https://github.com/bazelbuild/bazelisk/releases/download/v1.8.1/bazelisk-linux-amd64
sha256sums = 6c88924e211221f0bf6db33569b1c81f9dbc4b98fe57c0ff1f436005d3d559f1
+ sha256sums = 4a7652ffe904ccb064aaa7db41c456e742e507e574f58a602edbbc32920ed79b
pkgname = bazelisk
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..20190018b081
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.gz
+bazelisk-bin-*
diff --git a/PKGBUILD b/PKGBUILD
index 68b29a5e6daf..a1b845dd2803 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,40 @@
pkgname=bazelisk
pkgver=1.8.1
-pkgrel=1
-pkgdesc="A user-friendly launcher for Bazel."
-arch=("x86_64")
-license=("Apache 2.0")
-url="https://github.com/bazelbuild/bazelisk"
-makedepends=("bazel" "git")
-conflicts=("bazel")
-provides=("bazel")
-source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('6c88924e211221f0bf6db33569b1c81f9dbc4b98fe57c0ff1f436005d3d559f1')
+pkgrel=2
+pkgdesc='A user-friendly launcher for Bazel.'
+arch=('x86_64')
+license=('Apache')
+url='https://github.com/bazelbuild/bazelisk'
+makedepends=(
+ 'bazel' 'git')
+conflicts=('bazel')
+provides=('bazel')
+source=(
+ "bazelisk-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ "bazelisk-bin-${pkgver}::https://github.com/bazelbuild/bazelisk/releases/download/v${pkgver}/bazelisk-linux-amd64"
+)
+sha256sums=('6c88924e211221f0bf6db33569b1c81f9dbc4b98fe57c0ff1f436005d3d559f1'
+ '4a7652ffe904ccb064aaa7db41c456e742e507e574f58a602edbbc32920ed79b')
+
+prepare() {
+ chmod +x "${srcdir}/${source[1]%%::*}"
+}
build() {
- cd bazelisk-$pkgver
- bazel build //:bazelisk
+ cd "bazelisk-${pkgver}"
+ "${srcdir}/${source[1]%%::*}" build //:bazelisk
}
package() {
- cd bazelisk-$pkgver
- install -Dm755 bazel-bin/*/bazelisk "$pkgdir"/usr/bin/bazelisk
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/bazelisk/LICENSE
+ cd "bazelisk-${pkgver}"
+
+ install -Dm644 \
+ "LICENSE" \
+ "${pkgdir}/usr/share/licenses/bazelisk/LICENSE"
+
+ install -Dm755 \
+ "bazel-bin/bazelisk_/bazelisk" \
+ "${pkgdir}/usr/bin/${pkgname%isk}"
}