summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2021-05-13 08:46:43 -0600
committerBenjamin Denhartog2021-05-19 21:55:18 -0600
commitf4626dfae2aa980a8d8444d451297d21d33d2df8 (patch)
tree2655f6d6823282c175bf5e545ca6e5ebfda98ce8
parent3e1031dfbff4d07e253a300a852fa8b66ec3bfdd (diff)
downloadaur-f4626dfae2aa980a8d8444d451297d21d33d2df8.tar.gz
feat(bazelisk): standardize PKGBUILD files
This change brings in various changes to the PKGBUILD files in an attempt to standardize them. - Single quotes for variable values that do not include other variables - Dogfood bazelisk to avoid .bazelversion incompatibilities - Minor formatting changes - Rename license file from 'Apache 2.0' to 'Apache', as they are equal on Arch Linux systems GitOrigin-RevId: adcecf4608c54730a994084e0530e78260f3b51c
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD21
3 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4dfc52345fb..afc3428de60f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = bazelisk-bin
pkgdesc = A user-friendly launcher for Bazel
pkgver = 1.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bazelbuild/bazelisk
arch = x86_64
- license = Apache 2.0
+ license = Apache
provides = bazel
conflicts = bazel
- source = https://raw.githubusercontent.com/bazelbuild/bazelisk/v1.8.1/LICENSE
+ source = LICENSE-1.8.1::https://raw.githubusercontent.com/bazelbuild/bazelisk/v1.8.1/LICENSE
source = bazelisk-linux-amd64-1.8.1::https://github.com/bazelbuild/bazelisk/releases/download/v1.8.1/bazelisk-linux-amd64
sha256sums = c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4
sha256sums = 4a7652ffe904ccb064aaa7db41c456e742e507e574f58a602edbbc32920ed79b
diff --git a/.gitignore b/.gitignore
index 4401535d1f88..323d9c76bec4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,2 @@
-LICENSE
+LICENSE-*
bazelisk-linux-amd64*
diff --git a/PKGBUILD b/PKGBUILD
index d39a13abe0c6..f92937a87ca0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,26 @@
pkgname=bazelisk-bin
pkgver=1.8.1
-pkgrel=1
-pkgdesc="A user-friendly launcher for Bazel"
-url="https://github.com/bazelbuild/bazelisk"
-conflicts=('bazel')
+pkgrel=2
+pkgdesc='A user-friendly launcher for Bazel'
+url='https://github.com/bazelbuild/bazelisk'
+conflicts=("bazel")
provides=('bazel')
-license=('Apache 2.0')
+license=('Apache')
arch=('x86_64')
source=(
- "https://raw.githubusercontent.com/bazelbuild/bazelisk/v${pkgver}/LICENSE"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/bazelbuild/bazelisk/v${pkgver}/LICENSE"
"bazelisk-linux-amd64-${pkgver}::https://github.com/bazelbuild/bazelisk/releases/download/v${pkgver}/bazelisk-linux-amd64"
)
sha256sums=('c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4'
'4a7652ffe904ccb064aaa7db41c456e742e507e574f58a602edbbc32920ed79b')
package() {
- install -D -m 644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m 755 "${srcdir}/${source[1]%%::*}" "${pkgdir}/usr/bin/${pkgname%isk-bin}"
+ install -D -m 644 \
+ "${srcdir}/${source[0]%%::*}" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -D -m 755 \
+ "${srcdir}/${source[1]%%::*}" \
+ "${pkgdir}/usr/bin/${pkgname%isk-bin}"
}