summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2017-09-10 01:27:00 -0600
committerBrian Bidulock2017-09-10 01:27:00 -0600
commit08878903540fd1db7f73fa327c559dc399f0f5a3 (patch)
treef0e81ccce460b8b29882a895933335ecc08ba15f
downloadaur-08878903540fd1db7f73fa327c559dc399f0f5a3.tar.gz
initial version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
-rw-r--r--bbkeys.desktop14
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fe1a4d30681
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bbkeys-git
+ pkgdesc = Blackbox tool for setting keyboard shortcuts for manipulating windows and virtual desktop
+ pkgver = 0.9.1.11
+ pkgrel = 1
+ url = http://bbkeys.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ groups = blackbox
+ license = custom
+ makedepends = git
+ makedepends = blackbox-git
+ depends = libxext
+ depends = libxft
+ provides = bbkeys
+ conflicts = bbkeys
+ source = bbkeys-git::git+https://github.com/bbidulock/bbkeys.git
+ source = bbkeys.desktop
+ md5sums = SKIP
+ md5sums = ff91c4fec02f829820b369d5a0a4d000
+
+pkgname = bbkeys-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5856c8188b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: andrewy <andrew@andrewyates.net>
+#
+pkgname=bbkeys-git
+_pkgname=bbkeys
+pkgver=0.9.1.11
+pkgrel=1
+pkgdesc="Blackbox tool for setting keyboard shortcuts for manipulating windows and virtual desktop"
+arch=('i686' 'x86_64')
+url="http://bbkeys.sourceforge.net/"
+license=('custom')
+groups=('blackbox')
+depends=('libxext' 'libxft')
+makedepends=('git' 'blackbox-git')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$pkgname::git+https://github.com/bbidulock/$_pkgname.git"
+ "bbkeys.desktop")
+md5sums=('SKIP'
+ 'ff91c4fec02f829820b369d5a0a4d000')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags|sed -r 's,rel-([0-9])([0-9])([0-9]),\1.\2.\3,;s,^[^0-9]*,,;s,[-_],.,g;s,\.g.*$,,'
+}
+
+prepare() {
+ cd $pkgname
+ ./autogen.sh
+}
+
+build() {
+ cd $pkgname
+ ./configure
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+ install -m644 -D "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -m644 -D "../bbkeys.desktop" "$pkgdir/usr/share/applications/bbkeys.desktop"
+ install -m644 -D "../bbkeys.desktop" "$pkgdir/etc/xdg/autostart/bbkeys.desktop"
+}
diff --git a/bbkeys.desktop b/bbkeys.desktop
new file mode 100644
index 000000000000..8d20ab6a4442
--- /dev/null
+++ b/bbkeys.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=BlackBox Hot Keys
+GenericName=bbkeys
+Comment=Start keystroke detection for BlackBox
+Icon=keyboard
+OnlyShowIn=BLACKBOX;ICEWM;
+Exec=bbkeys
+TryExec=/usr/bin/bbkeys
+Terminal=false
+Categories=BLACKBOX;System;Utility;
+StartupNotify=false
+NoDisplay=true