summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2015-08-04 08:36:16 +0200
committerFadeMind2015-08-04 08:36:16 +0200
commita35bc9af62f4b502d7f455a34fdadab238773fb3 (patch)
treebdf0517763f1377fed93149f0648a1492a1ec23f
parent44de19cb7deaeaf09ca5658121bcc222139d7ac6 (diff)
downloadaur-a35bc9af62f4b502d7f455a34fdadab238773fb3.tar.gz
0.8-12
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
-rw-r--r--bbswitch-ck.install2
3 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84177c3ac676..666ce30c96d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = bbswitch-ck
pkgdesc = Kernel module allowing to switch dedicated graphics card on Optimus laptops for linux-ck
pkgver = 0.8
- pkgrel = 11
+ pkgrel = 12
url = http://github.com/Bumblebee-Project/bbswitch
install = bbswitch-ck.install
arch = i686
arch = x86_64
license = GPL
- makedepends = linux-ck-headers>=4.0
- makedepends = linux-ck-headers<4.1
- depends = linux-ck>=4.0
- depends = linux-ck<4.1
- source = https://github.com/Bumblebee-Project/bbswitch/archive/v0.8.tar.gz
+ makedepends = linux-ck-headers>=4.1
+ makedepends = linux-ck-headers<4.2
+ depends = linux-ck>=4.1
+ depends = linux-ck<4.2
+ provides = bbswitch
+ source = v0.8.tar.gz::http://github.com/Bumblebee-Project/bbswitch/archive/v0.8.tar.gz
md5sums = 5b116b31ace3604ddf9d1fc1f4bc5807
pkgname = bbswitch-ck
diff --git a/PKGBUILD b/PKGBUILD
index 34fe7ed0854e..be750ba9d830 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,30 @@
-# Maintainer: Boyan Ding <stu_dby@126.com>
+# Maintainer: FadeMind <fademind@gmail.com>
+# Contributor: Boyan Ding <stu_dby@126.com>
+_realname=bbswitch
+_extramodules=extramodules-4.1-ck # Don't forget to update bbswitch-ck.install
pkgname=bbswitch-ck
pkgver=0.8
-_realname=bbswitch
-_extramodules=extramodules-4.0-ck # Don't forget to update bbswitch-ck.install
-pkgrel=11
+pkgrel=12
pkgdesc="Kernel module allowing to switch dedicated graphics card on Optimus laptops for linux-ck"
arch=('i686' 'x86_64')
url=("http://github.com/Bumblebee-Project/bbswitch")
license=('GPL')
-depends=('linux-ck>=4.0' 'linux-ck<4.1')
-makedepends=('linux-ck-headers>=4.0' 'linux-ck-headers<4.1')
-install=bbswitch-ck.install
-source=("https://github.com/Bumblebee-Project/bbswitch/archive/v${pkgver}.tar.gz")
+depends=('linux-ck>=4.1' 'linux-ck<4.2')
+makedepends=('linux-ck-headers>=4.1' 'linux-ck-headers<4.2')
+provides=('bbswitch')
+install=${pkgname}.install
+source=("v${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
md5sums=('5b116b31ace3604ddf9d1fc1f4bc5807')
build() {
cd ${srcdir}/${_realname}-${pkgver}
-
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
-
make KDIR=/lib/modules/${_kernver}/build
}
package() {
cd ${srcdir}/${_realname}-${pkgver}
-
install -Dm644 bbswitch.ko "${pkgdir}"/usr/lib/modules/${_extramodules}/bbswitch.ko
gzip "${pkgdir}/usr/lib/modules/${_extramodules}/bbswitch.ko"
}
diff --git a/bbswitch-ck.install b/bbswitch-ck.install
index 8c877b0c17de..0306640437e8 100644
--- a/bbswitch-ck.install
+++ b/bbswitch-ck.install
@@ -1,5 +1,5 @@
post_install() {
- EXTRAMODULES='extramodules-4.0-ck'
+ EXTRAMODULES='extramodules-4.1-ck'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
}