summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Martucci2020-03-11 10:02:12 +0100
committerSimone Martucci2020-03-11 10:02:12 +0100
commita707643f100131ed1dcf2c51a63dc16e92cd118a (patch)
tree836943e091cc2b11eb946fd511fd881f59371634
parenta87de485906517cba11541467f285f421258de17 (diff)
downloadaur-a707643f100131ed1dcf2c51a63dc16e92cd118a.tar.gz
update for kernel 5.5
-rw-r--r--PKGBUILD15
-rw-r--r--bbswitch-ck.install2
2 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41eb75d3973e..0aac0d48f214 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,18 @@
# Contributor: Boyan Ding <stu_dby@126.com>
_realname=bbswitch
-_extramodules=extramodules-ck # Don't forget to update bbswitch-ck.install
+_minVer=5.5
+_maxVer=5.6
pkgname=bbswitch-ck
pkgver=0.8
-pkgrel=28
+pkgrel=29
+_kernver="$(uname -r)"
pkgdesc="Kernel module allowing to switch dedicated graphics card on Optimus laptops for linux-ck"
arch=('i686' 'x86_64')
url="http://github.com/Bumblebee-Project/bbswitch"
license=('GPL')
-depends=('linux-ck>=5.0' 'linux-ck<=5.1')
-makedepends=('linux-ck-headers>=5.0' 'linux-ck-headers<=5.1')
+depends=("linux-ck>=$_minVer" "linux-ck<=$_maxVer")
+makedepends=('linux-ck-headers')
provides=('bbswitch')
install=${pkgname}.install
source=("v${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
@@ -21,12 +23,11 @@ md5sums=('5b116b31ace3604ddf9d1fc1f4bc5807')
build() {
cd ${srcdir}/${_realname}-${pkgver}
- _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
make KDIR=/lib/modules/${_kernver}/build
}
package() {
cd ${srcdir}/${_realname}-${pkgver}
- install -Dm644 bbswitch.ko "${pkgdir}"/usr/lib/modules/${_extramodules}/bbswitch.ko
- gzip "${pkgdir}/usr/lib/modules/${_extramodules}/bbswitch.ko"
+ install -Dm644 bbswitch.ko "${pkgdir}"/usr/lib/modules/${_kernver}/bbswitch.ko
+ gzip "${pkgdir}/usr/lib/modules/${_kernver}/bbswitch.ko"
}
diff --git a/bbswitch-ck.install b/bbswitch-ck.install
index 38b4b144d8d4..6c68e68b2ad7 100644
--- a/bbswitch-ck.install
+++ b/bbswitch-ck.install
@@ -1,5 +1,5 @@
post_install() {
- EXTRAMODULES='extramodules-ck'
+ EXTRAMODULES='$(uname -r)'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
}