summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:10:01 +0200
committerMaxime Gauduin2015-06-08 11:10:01 +0200
commitba24f0418d3ca9ba1051749e66838f02da9cf299 (patch)
treecd65765ae88d29444fcc05a14dba97d1eb112794
downloadaur-ba24f0418d3ca9ba1051749e66838f02da9cf299.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
-rw-r--r--bbswitch-hook.install5
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8932700e16e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bbswitch-hook
+ pkgdesc = mkinitcpio hook to compile the bbswitch module
+ pkgver = 1.0
+ pkgrel = 2
+ url = https://github.com/alucryd/mkinitcpio-hooks
+ install = bbswitch-hook.install
+ arch = any
+ license = GPL3
+ depends = bbswitch-dkms
+ source = https://raw.github.com/alucryd/mkinitcpio-hooks/master/bbswitch
+ sha256sums = 9134827a9deab3ef787738976141b8ff573fd2b67681d61870c01f66c657bdae
+
+pkgname = bbswitch-hook
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17c890b45ea3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=bbswitch-hook
+pkgver=1.0
+pkgrel=2
+pkgdesc='mkinitcpio hook to compile the bbswitch module'
+url='https://github.com/alucryd/mkinitcpio-hooks'
+arch=('any')
+license=('GPL3')
+depends='bbswitch-dkms'
+install='bbswitch-hook.install'
+source=('https://raw.github.com/alucryd/mkinitcpio-hooks/master/bbswitch')
+sha256sums=('9134827a9deab3ef787738976141b8ff573fd2b67681d61870c01f66c657bdae')
+
+package() {
+ install -dm 755 "${pkgdir}"/usr/lib/initcpio/install
+ sed "s/_arch/$CARCH/" -i bbswitch
+ install -m 644 {,"${pkgdir}"/usr/lib/initcpio/install/}bbswitch
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/bbswitch-hook.install b/bbswitch-hook.install
new file mode 100644
index 000000000000..246c49dfb37f
--- /dev/null
+++ b/bbswitch-hook.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "Please add 'bbswitch' to the HOOKs array in /etc/mkinitcpio.conf and make sure you have installed the header files for your kernel to enable the automatic modules compilation."
+}
+
+# vim: ts=2 sw=2 et: