summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2015-06-08 11:41:56 +0200
committerFadeMind2015-06-08 11:41:56 +0200
commitaf8e1628f5029c6a01a36f635ba6d1cefaa4f019 (patch)
tree396e892f0edc2e527a554d194ebb4c1c0d2be0fd
downloadaur-af8e1628f5029c6a01a36f635ba6d1cefaa4f019.tar.gz
0.8-5
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--bbswitch-mainline.install12
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59f7cff39392
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bbswitch-mainline
+ pkgdesc = Kernel module allowing to switch dedicated graphics card on Optimus laptops for linux-mainline
+ pkgver = 0.8
+ pkgrel = 5
+ url = http://github.com/Bumblebee-Project/bbswitch
+ install = bbswitch-mainline.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = linux-mainline-headers>=4.1rc1
+ makedepends = linux-mainline-headers<4.2rc1
+ depends = linux-mainline>=4.1rc1
+ depends = linux-mainline<4.2rc1
+ provides = bbswitch
+ source = https://github.com/Bumblebee-Project/bbswitch/archive/v0.8.tar.gz
+ md5sums = 5b116b31ace3604ddf9d1fc1f4bc5807
+
+pkgname = bbswitch-mainline
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ef066035265
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: FadeMind <fademind@gmail.com>
+# Contributor: Boyan Ding <stu_dby@126.com> - Maintainer of bbswitch-ck
+
+_realname=bbswitch
+_extramodules=extramodules-4.1-mainline # Don't forget to update
+pkgname=bbswitch-mainline
+pkgver=0.8
+pkgrel=5
+pkgdesc="Kernel module allowing to switch dedicated graphics card on Optimus laptops for linux-mainline"
+arch=('i686' 'x86_64')
+url=("http://github.com/Bumblebee-Project/bbswitch")
+license=('GPL')
+depends=('linux-mainline>=4.1rc1' 'linux-mainline<4.2rc1')
+makedepends=('linux-mainline-headers>=4.1rc1' 'linux-mainline-headers<4.2rc1')
+provides=('bbswitch')
+install=${pkgname}.install
+source=("https://github.com/Bumblebee-Project/bbswitch/archive/v${pkgver}.tar.gz")
+md5sums=('5b116b31ace3604ddf9d1fc1f4bc5807')
+
+build() {
+ cd ${srcdir}/${_realname}-${pkgver}
+
+ _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+
+ make KDIR=/lib/modules/${_kernver}/build
+}
+
+package() {
+ cd ${srcdir}/${_realname}-${pkgver}
+
+ install -Dm644 bbswitch.ko "${pkgdir}"/usr/lib/modules/${_extramodules}/bbswitch.ko
+ gzip "${pkgdir}/usr/lib/modules/${_extramodules}/bbswitch.ko"
+}
diff --git a/bbswitch-mainline.install b/bbswitch-mainline.install
new file mode 100644
index 000000000000..e58146e4a1ea
--- /dev/null
+++ b/bbswitch-mainline.install
@@ -0,0 +1,12 @@
+post_install() {
+ EXTRAMODULES='extramodules-4.1-mainline'
+ depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}