summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2023-12-05 09:44:07 +0100
committerKlaus Alexander Seistrup2023-12-05 09:44:07 +0100
commit3e19b5d555748b2dfce1e23ada180643fc37e032 (patch)
tree79210c6acfbc2c91e68796866548d8dedeb51b63
parentf83a6d47e409931e881239ec48554d3fda9bc286 (diff)
downloadaur-3e19b5d555748b2dfce1e23ada180643fc37e032.tar.gz
New upstream release: v6.7.4
This is a production release to fix problems in the bc manual. Users only need to update if desired. Release notes: * https://github.com/gavinhoward/bc/releases/tag/6.7.4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 233dd3f8b7ec..4f640e422327 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bc-gh
pkgdesc = Implementation of dc and POSIX bc with GNU extensions
- pkgver = 6.7.3
- pkgrel = 2
+ pkgver = 6.7.4
+ pkgrel = 1
url = https://github.com/gavinhoward/bc
arch = aarch64
arch = arm
@@ -15,12 +15,12 @@ pkgbase = bc-gh
provides = bc
conflicts = bc
options = lto
- source = bc-gh-6.7.3.tar.xz::https://github.com/gavinhoward/bc/releases/download/6.7.3/bc-6.7.3.tar.xz
- source = bc-gh-6.7.3.tar.xz.sig::https://github.com/gavinhoward/bc/releases/download/6.7.3/bc-6.7.3.tar.xz.sig
+ source = bc-gh-6.7.4.tar.xz::https://github.com/gavinhoward/bc/releases/download/6.7.4/bc-6.7.4.tar.xz
+ source = bc-gh-6.7.4.tar.xz.sig::https://github.com/gavinhoward/bc/releases/download/6.7.4/bc-6.7.4.tar.xz.sig
validpgpkeys = FF360647C7A7147F27DAAEC1B132F881C306590A
- sha256sums = SKIP
- sha256sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
+ sha256sums = ce3bd42779c4534be80a2b9c8995b76acce62654879a4afd27001ed0e6bf602b
+ sha256sums = 0441941e895214051f38e139eeecef779856f2795e6388fd818672b2a7dd4002
+ sha512sums = 634d1e25884c9bced477a5c3e7a15923447a8a8e41808502e53039bf153c70f8475150b06b9d723d9c98605b3483e715bef11b1ebd4c18242f3daa9f0d133c45
+ sha512sums = 9af6b3b8890486cdc97e511a16e1fc1b78060fc66f8c4a1df59d0e1f5b95974ecaabffc52d13829f74a24bdaf0cacc84e08cb442d06e96492ce604747b7927cb
pkgname = bc-gh
diff --git a/PKGBUILD b/PKGBUILD
index d1901e4b05f4..3739222f2d6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# -*- mode: sh -*-
pkgname=bc-gh
-pkgver=6.7.3
-pkgrel=2
+pkgver=6.7.4
+pkgrel=1
pkgdesc="Implementation of dc and POSIX bc with GNU extensions"
arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'x86_64')
url="https://github.com/gavinhoward/bc"
@@ -18,17 +18,17 @@ source=(
"$pkgname-$pkgver.tar.xz.sig::$url/releases/download/$pkgver/bc-$pkgver.tar.xz.sig"
)
sha512sums=(
- 'SKIP'
- 'SKIP'
+ '634d1e25884c9bced477a5c3e7a15923447a8a8e41808502e53039bf153c70f8475150b06b9d723d9c98605b3483e715bef11b1ebd4c18242f3daa9f0d133c45'
+ '9af6b3b8890486cdc97e511a16e1fc1b78060fc66f8c4a1df59d0e1f5b95974ecaabffc52d13829f74a24bdaf0cacc84e08cb442d06e96492ce604747b7927cb'
)
sha256sums=(
- 'SKIP'
- 'SKIP'
+ 'ce3bd42779c4534be80a2b9c8995b76acce62654879a4afd27001ed0e6bf602b'
+ '0441941e895214051f38e139eeecef779856f2795e6388fd818672b2a7dd4002'
)
validpgpkeys=('FF360647C7A7147F27DAAEC1B132F881C306590A')
_ltoflags='-flto=auto'
-: "${LTOFLAGS:-$_ltoflags}"
+: "${LTOFLAGS:=$_ltoflags}"
build() {
cd "bc-$pkgver"
@@ -49,10 +49,13 @@ package() {
DESTDIR="$pkgdir" make install
- install -Dm0644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ # If we have a tty, tell the user what we are doing
+ test -t 1 && _verbose='v' || _verbose=''
+
+ install "-${_verbose}Dm0644" LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
for _doc in {NEWS,NOTICE,README}.md; do
- install -Dm0644 "$_doc" "$pkgdir/usr/share/doc/$pkgname/$_doc"
+ install "-${_verbose}Dm0644" "$_doc" "$pkgdir/usr/share/doc/$pkgname/$_doc"
done
}