summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTankMissile2020-07-01 06:59:54 -0400
committerTankMissile2020-07-01 06:59:54 -0400
commitc26d1c6de8d5b1b0523414f8cdb60cc694f94c41 (patch)
treec88335322acddd6c3916fadfed1f23f95b592a78
parent421de15ff8d6f3e190f178b94571b7a16cbdb4c9 (diff)
downloadaur-c26d1c6de8d5b1b0523414f8cdb60cc694f94c41.tar.gz
PKGBUILD and changelog cleanup.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD70
-rw-r--r--bcache-tools-git.changelog36
-rw-r--r--crc64.patch11
-rw-r--r--initcpio-dracut-arch.patch22
5 files changed, 78 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ab6d4874b6e..f7ddb7b87a4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = bcache-tools-git
- pkgdesc = Userspace tools for bcache until bcache merges with either dm or md
+ pkgdesc = Userspace tools for bcache until bcache merges with either dm or md (git version).
pkgver = 1.0.8.r0.ga73679b
pkgrel = 1
url = http://bcache.evilpiepirate.org/
@@ -12,10 +12,10 @@ pkgbase = bcache-tools-git
depends = util-linux
provides = bcache-tools
conflicts = bcache-tools
- source = git+https://github.com/g2p/bcache-tools.git
- source = initcpio-arch.patch
- md5sums = SKIP
- md5sums = 208d7024340b8db3cf21325df40b6267
+ source = git+https://git.kernel.org/pub/scm/linux/kernel/git/colyli/bcache-tools.git
+ source = initcpio-dracut-arch.patch
+ sha256sums = SKIP
+ sha256sums = fea3ddfcef7aaac6cc6dd0c5497bc5f69f799d4f9f286e978ebd4b9326347f9c
pkgname = bcache-tools-git
diff --git a/PKGBUILD b/PKGBUILD
index eb085484e42b..8fb496b4a936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,49 @@
-# Maintainer: Justin Dray <justin@dray.be>
-# Previous maintainer: bobpaul (bobpaul on archlinux forumsBoohbah <boohbah at gmail.com>)
+# Maintainer: TankMissile <alecfeldman@disroot.org>
+# Contributor: Justin Dray <justin@dray.be>
+# Contributor: bobpaul <boohbah@gmail.com>
# Contributor: Mikeserv
-_gitname=bcache-tools
-pkgname=${_gitname}-git
+_pkgname=bcache-tools
+pkgname=$_pkgname-git
pkgver=1.0.8.r0.ga73679b
pkgrel=1
-pkgdesc="Userspace tools for bcache until bcache merges with either dm or md"
changelog=bcache-tools-git.changelog
-arch=('i686' 'x86_64')
+pkgdesc="Userspace tools for bcache until bcache merges with either dm or md (git version)."
url="http://bcache.evilpiepirate.org/"
-license=('GPL')
-depends=('util-linux')
-makedepends=('git')
-provides=('bcache-tools')
-conflicts=('bcache-tools')
-install="${pkgname}.install"
-source=("git+https://github.com/g2p/${_gitname}.git"
- 'crc64.patch'
- 'initcpio-arch.patch')
-md5sums=('SKIP'
- '265f3d6ad0bd1596eac8a2c3512f2d87'
- '208d7024340b8db3cf21325df40b6267')
-
-# set _gitrev to a git revision (man gitrevisions) like a tag, a commit sha1
-# hash or a branch name to build from this tree instead of master
-
-# _gitrev=""
-#_gitrev="89f11b135d1"
+arch=("i686" "x86_64")
+license=("GPL")
+depends=("util-linux")
+makedepends=("git")
+provides=("bcache-tools")
+conflicts=("bcache-tools")
+install="$pkgname.install"
+source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/colyli/$_pkgname.git"
+ "initcpio-dracut-arch.patch")
+sha256sums=("SKIP"
+ "fea3ddfcef7aaac6cc6dd0c5497bc5f69f799d4f9f286e978ebd4b9326347f9c")
pkgver() {
- cd "${srcdir}/${_gitname}"
- [[ -n $_gitrev ]] && git reset --hard "$_gitrev"
- git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//'
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "${srcdir}/${_gitname}"
- patch -Np1 -i "${srcdir}/initcpio-arch.patch"
- patch -Np1 -i "${srcdir}/crc64.patch"
+ cd $_pkgname
+ patch -Np1 -i "$srcdir/initcpio-dracut-arch.patch"
}
build() {
- cd "${srcdir}/${_gitname}"
- make
+ cd $_pkgname
+ make
}
package() {
- cd "${srcdir}/${_gitname}"
- mkdir -p "${pkgdir}/usr/bin"
- mkdir -p "${pkgdir}/usr/lib/udev/rules.d"
- mkdir -p "${pkgdir}/usr/share/man/man8"
- mkdir -p "${pkgdir}/usr/lib/initcpio/install"
-
- make DESTDIR="${pkgdir}" install
+ cd $_pkgname
+ install -d \
+ "$pkgdir/usr/bin" \
+ "$pkgdir/usr/lib/udev/rules.d" \
+ "$pkgdir/usr/share/man/man8" \
+ "$pkgdir/usr/lib/initcpio/install"
+
+ make DESTDIR="$pkgdir" install
}
diff --git a/bcache-tools-git.changelog b/bcache-tools-git.changelog
index 238e8c64cd3a..fe35cbd4b25e 100644
--- a/bcache-tools-git.changelog
+++ b/bcache-tools-git.changelog
@@ -1,21 +1,25 @@
2013-01-07
- * Added dependency on util-linux
- * Fixed up now-unecessary patches due to initcpio udev hook being applied upstream
- * Added warning on update to change mkinitcpio.conf to use bcache rule instead of the now-defunct bcache_udev
- * Fixed minor packaging issues that caused namcap to complain
- * Changed versioning method as there are now unannotated tags available
+ * Added dependency on util-linux.
+ * Fixed up now-unecessary patches due to initcpio udev hook being applied upstream.
+ * Added warning on update to change mkinitcpio.conf to use bcache rule instead of the now-defunct bcache_udev.
+ * Fixed minor packaging issues that caused namcap to complain.
+ * Changed versioning method as there are now unannotated tags available.
-2014-01-06
- * Added conflicts/provides to support bcache-tools package
- * Changed to tracking g2p's version of bcache-tools as it has tagged versions for the non-git release
+2013-03-10
+ * First package. Forked from f2fs-tools-git package.
+ * created arch.patch to remove upstreem initcpio stuff (probably for fedora) and add in arch linux initcpio bcache hook.
2013-11-28
- * Took over as maintainer (Justin Dray)
- * Updated to work with the latest git version
- * Added a working udev rule written by Mikeserv, adapted from mdadm
- * Removed unecessary patches
- * Updated to comply with current VCS PKGBUILD guidelines
+ * Took over as maintainer (Justin Dray).
+ * Updated to work with the latest git version.
+ * Added a working udev rule written by Mikeserv, adapted from mdadm.
+ * Removed unecessary patches.
+ * Updated to comply with current VCS PKGBUILD guidelines.
-2013-03-10
- * First package. Forked from f2fs-tools-git package.
- * created arch.patch to remove upstreem initcpio stuff (probably for fedora) and add in arch linux initcpio bcache hook
+2014-01-06
+ * Added conflicts/provides to support bcache-tools package.
+ * Changed to tracking g2p's version of bcache-tools as it has tagged versions for the non-git release.
+
+2020-07-01
+ * Removed crc64.patch as it's no longer needed.
+ * Added dracut support.
diff --git a/crc64.patch b/crc64.patch
deleted file mode 100644
index 511c376f3e95..000000000000
--- a/crc64.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/bcache.c
-+++ b/bcache.c
-@@ -115,7 +115,7 @@ static const uint64_t crc_table[256] = {
- 0x9AFCE626CE85B507ULL
- };
-
--inline uint64_t crc64(const void *_data, size_t len)
-+uint64_t crc64(const void *_data, size_t len)
- {
- uint64_t crc = 0xFFFFFFFFFFFFFFFFULL;
- const unsigned char *data = _data;
diff --git a/initcpio-dracut-arch.patch b/initcpio-dracut-arch.patch
new file mode 100644
index 000000000000..ad7ccb8635db
--- /dev/null
+++ b/initcpio-dracut-arch.patch
@@ -0,0 +1,22 @@
+diff --git a/Makefile b/Makefile
+index 4359866..854a473 100644
+--- a/Makefile
++++ b/Makefile
+@@ -8,13 +8,12 @@ CFLAGS+=-O2 -Wall -g
+ all: make-bcache probe-bcache bcache-super-show bcache-register bcache
+
+ install: make-bcache probe-bcache bcache-super-show
+- $(INSTALL) -m0755 make-bcache bcache-super-show bcache $(DESTDIR)${PREFIX}/sbin/
+- $(INSTALL) -m0755 probe-bcache bcache-register $(DESTDIR)$(UDEVLIBDIR)/
+- $(INSTALL) -m0644 69-bcache.rules $(DESTDIR)$(UDEVLIBDIR)/rules.d/
++ $(INSTALL) -m0755 make-bcache bcache-super-show $(DESTDIR)${PREFIX}/bin/
++ $(INSTALL) -m0755 probe-bcache bcache-register $(DESTDIR)${PREFIX}$(UDEVLIBDIR)/
++ $(INSTALL) -m0644 69-bcache.rules $(DESTDIR)${PREFIX}$(UDEVLIBDIR)/rules.d/
+ $(INSTALL) -m0644 -- *.8 $(DESTDIR)${PREFIX}/share/man/man8/
+- $(INSTALL) -D -m0755 initramfs/hook $(DESTDIR)/usr/share/initramfs-tools/hooks/bcache
+ $(INSTALL) -D -m0755 initcpio/install $(DESTDIR)/usr/lib/initcpio/install/bcache
+- $(INSTALL) -D -m0755 dracut/module-setup.sh $(DESTDIR)$(DRACUTLIBDIR)/modules.d/90bcache/module-setup.sh
++ $(INSTALL) -D -m0755 dracut/module-setup.sh $(DESTDIR)${PREFIX}$(DRACUTLIBDIR)/modules.d/90bcache/module-setup.sh
+ # $(INSTALL) -m0755 bcache-test $(DESTDIR)${PREFIX}/sbin/
+
+ clean: