summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Devir2020-01-10 07:41:44 +1000
committerKyle Devir2020-01-10 07:41:44 +1000
commit2b4eb31f3855cbb38499d4f4096b3c973812ac6b (patch)
tree835d35cfbfe0836a4f708cec5f01cf50b639b606
parent0f8b1ec8725df4e5c028a77737afb3a8a59e69a8 (diff)
downloadaur-2b4eb31f3855cbb38499d4f4096b3c973812ac6b.tar.gz
PKGBUILD updates
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD34
2 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2896060ec10..0172d5e59038 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,8 +24,8 @@ pkgbase = bcachefs-tools-git
provides = bcachefs-tools
source = git+https://github.com/koverstreet/bcachefs-tools
source = add-mkinitcpio-hook-for-Arch.patch
- sha256sums = SKIP
- sha256sums = 659483e9d5106826f6f6a894de189d895635c6e8790d216a8635c7cc59e27efc
+ sha512sums = SKIP
+ sha512sums = e75e0fc9576990d910acf5a3eafb1f83ab7d407bddcc210c9926b048ceb3ef018749654ca6a6ebdfab45a3e00031f6bb3537d2f3f19e3a7ec3be7c470d4ce7df
pkgname = bcachefs-tools-git
diff --git a/PKGBUILD b/PKGBUILD
index e0c5b6df0bba..f7897df8427b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@ pkgver=551
pkgrel=1
pkgdesc="BCacheFS filesystem utilities"
url="https://github.com/koverstreet/bcachefs-tools"
-arch=(x86_64)
-license=(GPL2)
-install="${pkgname}.install"
+arch=("x86_64")
+license=("GPL2")
+install="$pkgname.install"
provides=(bcachefs-tools)
makedepends=(
@@ -31,40 +31,42 @@ depends=(
)
_reponame="bcachefs-tools"
-_repo_url="https://github.com/koverstreet/${_reponame}"
+_repo_url="https://github.com/koverstreet/$_reponame"
source=(
- "git+${_repo_url}"
+ "git+$_repo_url"
"add-mkinitcpio-hook-for-Arch.patch"
)
-sha256sums=('SKIP'
- '659483e9d5106826f6f6a894de189d895635c6e8790d216a8635c7cc59e27efc')
+sha512sums=('SKIP'
+ 'e75e0fc9576990d910acf5a3eafb1f83ab7d407bddcc210c9926b048ceb3ef018749654ca6a6ebdfab45a3e00031f6bb3537d2f3f19e3a7ec3be7c470d4ce7df')
pkgver() {
- cd "${srcdir}/${_reponame}"
+ cd "$srcdir/$_reponame"
echo "$(git rev-list --count HEAD)"
}
prepare() {
- cd "${srcdir}/${_reponame}"
+ cd "$srcdir/$_reponame"
- patch -Np1 -i "../add-mkinitcpio-hook-for-Arch.patch"
+ PName="add-mkinitcpio-hook-for-Arch.patch"
+ msg2 "Patching with $PName ..."
+ patch -Np1 -i "../$PName"
}
build() {
- cd "${srcdir}/${_reponame}"
+ cd "$srcdir/$_reponame"
- make EXTRA_CFLAGS="-O0"
+ make EXTRA_CFLAGS="-O2"
}
package() {
- cd "${srcdir}/${_reponame}"
+ cd "$srcdir/$_reponame"
- make DESTDIR="${pkgdir}" PREFIX="/usr" ROOT_SBINDIR="/usr/bin" INITRAMFS_DIR="/etc/initcpio" install
+ make DESTDIR="$pkgdir" PREFIX="/usr" ROOT_SBINDIR="/usr/bin" INITRAMFS_DIR="/etc/initcpio" install
install -Dm644 "arch/etc/initcpio/hooks/bcachefs" \
- "${pkgdir}/etc/initcpio/hooks/bcachefs"
+ "$pkgdir/etc/initcpio/hooks/bcachefs"
install -Dm644 "arch/etc/initcpio/install/bcachefs" \
- "${pkgdir}/etc/initcpio/install/bcachefs"
+ "$pkgdir/etc/initcpio/install/bcachefs"
}