summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2019-01-14 15:27:37 +1000
committerKyle De'Vir2019-01-14 15:27:37 +1000
commitde00453072e58143dc5ffd10bb2744fc3d9fa80b (patch)
treea3ee008f7df15c900ddc5aa73d052af5e114dc88
parent78e7d76284c45b8863d779cc647369c8f1dc3aeb (diff)
downloadaur-de00453072e58143dc5ffd10bb2744fc3d9fa80b.tar.gz
Add .install file
-rw-r--r--PKGBUILD1
-rw-r--r--bcachefs-tools-git.install16
2 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04a0edb2949c..e50df6bc6e47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,7 @@ pkgdesc="bcachefs filesystem utilities"
url="https://evilpiepirate.org/git/bcachefs-tools.git/"
arch=("x86_64")
license=("GPL2")
+install="${pkgname}.install"
provides=("bcachefs-tools")
makedepends=("git" "libscrypt" "libsodium" "attr" "libutil-linux" "keyutils" "pkgconf" "zlib" "liburcu")
diff --git a/bcachefs-tools-git.install b/bcachefs-tools-git.install
new file mode 100644
index 000000000000..f9ac55335bfc
--- /dev/null
+++ b/bcachefs-tools-git.install
@@ -0,0 +1,16 @@
+post_upgrade() {
+ echo "If you haven't already, please manually add 'bcachefs' to mkinitcpio.conf variables 'MODULES=()', 'BINARIES=()', and 'HOOKS=()'"
+ echo "and then run 'mkinitcpio -p linux-bcachefs-git'"
+}
+
+post_install() {
+ echo "Please manually add 'bcachefs' to mkinitcpio.conf variables 'MODULES=()', 'BINARIES=()', and 'HOOKS=()'"
+ echo "and then run 'mkinitcpio -p linux-bcachefs-git'"
+}
+
+post_remove() {
+ echo "Please manually remove 'bcachefs' to mkinitcpio.conf variables 'MODULES=()', 'BINARIES=()', and 'HOOKS=()'"
+ echo "and then run 'mkinitcpio -p linux-bcachefs-git'"
+}
+
+# vim:set ft=sh ts=8 sts=2 sw=2 et: