summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2022-07-31 10:04:03 +0200
committerkleintux2022-07-31 10:04:03 +0200
commitba4ac1f746ffdeecf3d9b9ab92ee4c98bfac7cae (patch)
tree60730b685ada0556cda44404c5aa974cecd82a6f
parentd49cfcfedb0c1041b57235bbb37e3779dfbed92d (diff)
downloadaur-bcal.tar.gz
adopted. fixed some stuff. updated to 2.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 963b71f6fd72..54f8da66a82a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = bcal
pkgdesc = Storage conversion and expression calculator
- pkgver = 2.2
+ pkgver = 2.4
pkgrel = 1
url = https://github.com/jarun/bcal
arch = i686
arch = x86_64
+ arch = aarch64
license = GPL3
- provides = bcal
- conflicts = bcal-git
- source = https://github.com/jarun/bcal/archive/v2.2.tar.gz
- sha256sums = 506d17d6df35fad636d3ced425afee5921cd2b21242099b78b369cfcb5716e23
+ depends = readline
+ depends = bc
+ source = bcal-2.4.tar.gz::https://github.com/jarun/bcal/archive/v2.4.tar.gz
+ sha256sums = 141f39d866f62274b2262164baaac6202f60749862c84c2e6ed231f6d03ee8df
pkgname = bcal
-
diff --git a/PKGBUILD b/PKGBUILD
index 8269721f7db3..09d7401ab3fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Pablo Arias <pabloariasal@gmail.com>
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Pablo Arias <pabloariasal@gmail.com>
# Contributor: John Jenkins <twodopeshaggy@gmail.com>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=bcal
-pkgver=2.2
+pkgver=2.4
pkgrel=1
pkgdesc="Storage conversion and expression calculator"
-arch=("i686" "x86_64")
+arch=("i686" "x86_64" "aarch64")
url="https://github.com/jarun/bcal"
license=('GPL3')
-source=("https://github.com/jarun/bcal/archive/v${pkgver//_/-}.tar.gz")
-sha256sums=('506d17d6df35fad636d3ced425afee5921cd2b21242099b78b369cfcb5716e23')
-conflicts=('bcal-git')
-provides=('bcal')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/jarun/bcal/archive/v${pkgver//_/-}.tar.gz")
+depends=('readline' 'bc')
+sha256sums=('141f39d866f62274b2262164baaac6202f60749862c84c2e6ed231f6d03ee8df')
package() {
- make -C "${pkgname}-${pkgver}" DESTDIR="${pkgdir}" PREFIX="/usr" install > /dev/null
+ make -C "${pkgname}-${pkgver}" DESTDIR="${pkgdir}" PREFIX="/usr" install
}