summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Arias2018-04-16 22:33:58 -0500
committerPablo Arias2018-04-16 22:33:58 -0500
commitece6d11d2b612211574aa2ba3d2fa146995eebf5 (patch)
tree9289ce30c7557c9ac2e99d590ed39ca691796a00
parent3e8b8dad7348300426ffba90632f9b1706ab2e2b (diff)
downloadaur-ece6d11d2b612211574aa2ba3d2fa146995eebf5.tar.gz
Reworked PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e3989cf02db..a1523487bbca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Oct 4 20:48:25 UTC 2016
pkgbase = bcal-git
- pkgdesc = Byte CALculator. The engineer's utility for storage conversions and calculations.
- pkgver = 35.68f5bba
+ pkgdesc = Storage conversion and expression calculator
+ pkgver = 1.8.r5.g0fde1c6
pkgrel = 1
url = https://github.com/jarun/bcal
arch = i686
@@ -10,7 +8,7 @@ pkgbase = bcal-git
license = GPL3
provides = bcal
conflicts = bcal
- source = bcal::git+https://github.com/jarun/bcal.git
+ source = git+https://github.com/jarun/bcal.git
sha256sums = SKIP
pkgname = bcal-git
diff --git a/PKGBUILD b/PKGBUILD
index 4ff6577c3219..6568aeda2e2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
-# Maintainer: John Jenkins <twodopeshaggy@gmail.com>
+# Maintainer: Pablo Arias <pabloariasal@gmail.com>
+# Contributor: John Jenkins <twodopeshaggy@gmail.com>
pkgname=bcal-git
_pkgname=bcal
-pkgver=35.68f5bba
+pkgver=1.8.r5.g0fde1c6
pkgrel=1
-pkgdesc="Byte CALculator. The engineer's utility for storage conversions and calculations."
+pkgdesc="Storage conversion and expression calculator"
arch=("i686" "x86_64")
url="https://github.com/jarun/bcal"
license=('GPL3')
-source=(${_pkgname}::"git+https://github.com/jarun/${_pkgname}.git")
+source=("git+https://github.com/jarun/${_pkgname}.git")
sha256sums=('SKIP')
conflicts=('bcal')
provides=('bcal')
pkgver() {
cd "${srcdir}/${_pkgname}"
- echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ git describe --long | sed 's/v\([^-]*-\)/\1r/;s/-/./g'
}
package() {