summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Knapp2018-09-20 13:05:23 -0700
committerJonathan Knapp2018-09-20 13:05:23 -0700
commit57fec0664edecf1cd8e84520f7a48b49082d87cd (patch)
tree7112d6bc8c2e1d1c42664ea63f0911b96c4201ab
downloadaur-57fec0664edecf1cd8e84520f7a48b49082d87cd.tar.gz
Init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82ba0da6f649
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bcash-git
+ pkgdesc = An alternative implementation of the Bitcoin Cash protocol, written in node.js.
+ pkgver = 1.0.2.4.g28cf1ef8
+ pkgrel = 1
+ url = https://github.com/bcoin-org/bcash
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ makedepends = python2
+ depends = nodejs
+ provides = bcash
+ conflicts = bcash
+ source = bcash-git::git+https://github.com/bcoin-org/bcash.git
+ md5sums = SKIP
+
+pkgname = bcash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a8039828cf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jonathan Knapp <jaknapp8+aur@gmail.com>
+# Contributor: Christopher Jeffrey
+# URL: https://github.com/bcoin-org/bcash
+# Upstream: https://github.com/bcoin-org/bcash
+
+pkgname=bcash-git
+pkgver=1.0.2.4.g28cf1ef8
+pkgrel=1
+pkgdesc='An alternative implementation of the Bitcoin Cash protocol, written in node.js.'
+arch=('i686' 'x86_64')
+url='https://github.com/bcoin-org/bcash'
+license=('MIT')
+depends=('nodejs')
+makedepends=('git' 'npm' 'python2')
+provides=('bcash')
+conflicts=('bcash')
+source=("$pkgname::git+https://github.com/bcoin-org/bcash.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tag | sed 's/^v//;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ npm install -g --prefix "$pkgdir"/usr --user root --unsafe-perm
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ #HACK: npm is being lame and only installing a symlink =/
+ rm "$pkgdir/usr/lib/node_modules/bcash"
+ find * -exec install -D -m644 "{}" "$pkgdir/usr/lib/node_modules/bcash/{}" \;
+ find "$pkgdir/usr/lib/node_modules/bcash" -exec chmod +x "{}" \;
+ #HACK: remove references to $srcdir & $pkgdir (if you care)
+ # npm install -g removeNPMAbsolutePaths --prefix "$pkgdir"/usr
+ # "$pkgdir"/usr/bin/removeNPMAbsolutePaths "$pkgdir"/usr
+ # npm uninstall -g removeNPMAbsolutePaths --prefix "$pkgdir"/usr
+}