summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2018-02-24 18:46:12 +0100
committerGordian Edenhofer2018-02-24 18:51:50 +0100
commit32b58c909e2f356fd80a3adc8d1dc4c648d444cc (patch)
treeb13dd142e0d568ace043ecec71d8ee3cc87b7a25
parent7b33cd7cd5d96696d07f8299a073068aea1d719e (diff)
downloadaur-32b58c909e2f356fd80a3adc8d1dc4c648d444cc.tar.gz
upgpkg: bcc 0.5.0-2
Update the checksum of the git-commit to be consistent with the downloaded file instead of the previously used patch.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95ad6f80666a..5c1f947068af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bcc
pkgdesc = BPF Compiler Collection
pkgver = 0.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/iovisor/bcc
arch = x86_64
license = Apache
@@ -15,9 +15,9 @@ pkgbase = bcc
makedepends = python
makedepends = python2
source = https://github.com/iovisor/bcc/archive/v0.5.0.tar.gz
- source = fix_build_issue_for_llvm_5.0.1.patch::https://github.com/iovisor/bcc/commit/bd7fa55bb39b8978dafd0b299e35616061e0a368.patch
+ source = cherry-fix_build_issue_for_llvm_5.0.1.patch::https://github.com/iovisor/bcc/commit/bd7fa55bb39b8978dafd0b299e35616061e0a368.patch
sha512sums = 12de5ef04185dccd0847fc97ae855b386e0c81b545ae497af797667925ebedf97164c17fb99468abae3f87fb3ddfdba5200070f80b3bbcad63c2355497012f0e
- sha512sums = 1c4a453a0663237b1ebebd4fdc60e7f6add8380bf624cfa6dd28e57a73d6db89b0a562c8bcaa788d8d59f69240b574b123d07e1eeb63da3a255d3b5e40c6221b
+ sha512sums = f518f32584b1f828af5df00972c33e6efc7f4327fd65505156e6dec96e4e2f6e7fafb50fb0855693d586223dce4f6cbf7db34ae252358636decc5dbe7f6121a7
pkgname = bcc
pkgdesc = BPF Compiler Collection - C library and examples
diff --git a/PKGBUILD b/PKGBUILD
index 73d008406431..8c864d5aa941 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=bcc
pkgname=('bcc' 'bcc-tools' 'python-bcc' 'python2-bcc')
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc='BPF Compiler Collection'
arch=('x86_64')
url='https://github.com/iovisor/bcc'
@@ -12,14 +12,14 @@ license=('Apache')
makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison' 'python' 'python2')
checkdepends=('netperf' 'iperf')
source=("https://github.com/iovisor/${pkgname}/archive/v${pkgver}.tar.gz"
- 'fix_build_issue_for_llvm_5.0.1.patch::https://github.com/iovisor/bcc/commit/bd7fa55bb39b8978dafd0b299e35616061e0a368.patch')
+ 'cherry-fix_build_issue_for_llvm_5.0.1.patch::https://github.com/iovisor/bcc/commit/bd7fa55bb39b8978dafd0b299e35616061e0a368.patch')
sha512sums=('12de5ef04185dccd0847fc97ae855b386e0c81b545ae497af797667925ebedf97164c17fb99468abae3f87fb3ddfdba5200070f80b3bbcad63c2355497012f0e'
- '1c4a453a0663237b1ebebd4fdc60e7f6add8380bf624cfa6dd28e57a73d6db89b0a562c8bcaa788d8d59f69240b574b123d07e1eeb63da3a255d3b5e40c6221b')
+ 'f518f32584b1f828af5df00972c33e6efc7f4327fd65505156e6dec96e4e2f6e7fafb50fb0855693d586223dce4f6cbf7db34ae252358636decc5dbe7f6121a7')
prepare() {
cd "${srcdir}/${pkgbase}-${pkgver}"
- patch -Np1 -i "${srcdir}/fix_build_issue_for_llvm_5.0.1.patch"
+ patch -Np1 -i "${srcdir}/cherry-fix_build_issue_for_llvm_5.0.1.patch"
}
build() {